This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 536329 - (RHQ-691) Support compiling RHQ with JDK1.6
Support compiling RHQ with JDK1.6
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Jason Dobies
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-07-18 18:56 EDT by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2008-07-18 18:56:00 EDT
From joseph:
"yes, i downed-graded back to 3.3 and i still see them too.  it only happens when i have java6 as my execution environment.  if i revert to java5, the compile errors go away.  so it appears that some of the interfaces in the java.sql package weren't backwards compatible, because of new method additions in them.

Jeff Weiss wrote:
> Joseph Marques wrote:
>  
>> ok eclipse people, so the classpath file for the rhq project references
>> a java6 runtime, but if i leave that be then i get 35 or so compile
>> errors in the dbutils project.  files like LoggerConnection,
>> LoggerStatement, and LoggerPreparedStatement.  if i switch the classpath
>> to reference java5, these errors go away.  has any other eclipse users
>> seen this yet?
>>
>> also, regardless of java5/6, i'm getting a compile error in a few of the
>> modules that reference XmlConstants.W3C_XML_SCHEMA_NS_URI.  i've ignored
>> them for now because things are building fine from the command line, but
>> i can't figure out why things complain inside eclipse.
>>
>>     
>
> I saw the issue where there were compile errors in dbutils earlier this
> week.  I am running eclipse 3.3.
>
> Jeff "
Comment 1 Jeff Weiss 2008-07-21 09:51:50 EDT
Since this doesn't need to be QA'd, let's move this to the issue type "Task" (which is one of the types that skips the QA part of the workflow - the others are code-change and subtask).
Comment 2 Greg Hinkle 2008-07-29 22:11:57 EDT
Jason's working on this
Comment 3 Jeff Weiss 2008-08-19 16:25:51 EDT
I actually tested this, checked out RHQ rev1260, and built it with jdk 1.6. No errors.  I didn't do any regression testing against what I built though.
Comment 4 Red Hat Bugzilla 2009-11-10 16:14:51 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-691
This bug is related to RHQ-3

Note You need to log in before you can comment on or make changes to this bug.