Bug 53634 - Search for 'com_err' returns lots of pages that don't have any occurrences of that word
Search for 'com_err' returns lots of pages that don't have any occurrences of...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.8
i386 Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
https://bugzilla.redhat.com/bugzilla/...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 12:14 EDT by Ed Avis
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-13 14:52:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2001-09-13 12:14:21 EDT
Description of Problem: Bugzilla search for 'com_err' returns lots of false
positives.

Version-Release number of selected component (if applicable): 
whatever bugzilla.redhat.com/bugzilla/ is running


How Reproducible: go to query page and enter 'com_err' in Description
field, leave all other query narrowing things blank.


Actual Results: a big list of bugs is returned.  The first bug in the list
(673) is a correct match, it has occurrences of the string 'com_err', but
the second bug (1016) does not contain this string.


Expected Results: as a minimum I'd expect that searching for a string would
restrict the search results to pages containing that string.


Additional Information: speculation: maybe this is related to the
underscore in the search string.  Perhaps Bugzilla is splitting 'com_err'
into two words and matching them separately (in 'redhat.com' and 'errata'
perhaps).  That would not be sensible since underscore is usually
considered an honorary letter of the alphabet, something separated by
underscores should be treated as a single nondivisible word.
Comment 1 Aleksey Nogin 2002-12-13 14:52:13 EST
Seems to work correctly now.

Note You need to log in before you can comment on or make changes to this bug.