This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 536348 - (RHQ-707) Recursive groups inventory needs better navigation or search
Recursive groups inventory needs better navigation or search
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Inventory (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-01 15:23 EDT by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
all
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
jweiss: archived+


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2008-08-01 15:23:00 EDT
To see the need for this improvement:

Create a new mixed recursive group, add the platform to it.  Now add a few other resources.

Now in the group view you'll have many pages of resources.  How can you find a particular resource?   You can sort by different columns, but if you item isn't on the first page, you have to guess what page it's on and click around until you find it.

Granted, the only reason I can think of to look for something here, rather than on the Resource Browser, is to remove it from the group.  However it would be nice to be able to look at a group view and be able to find anything, not just items explicitly added to the group.  Can we add the same search functionality here as we have on the Resource Browser?

The other (less desirable, IMO) solution is to be able to sort by whether the item has a checkbox (and hence can be removed from the group).  This will help you find something if you want to remove it, but not if you're just browsing the group.
Comment 1 John Mazzitelli 2008-11-08 19:36:52 EST
there is another reason for this.

I had a recursive group of 20K resources.  Due to a bug, I can't delete the entire group. So I have to remove as many resources as I can until I shrink the group down enought until it can be deleted.

I have to page through the entire 20K list of resources to find those that are directly removeable from this recursive group (the ones with the checkboxes).  Very tedious.  There are only 200 or so that I need to remove, 1% of the entire membership.

In my case, if I could just sort on the checkbox column, that's what I would need (so I can see all the resources that are removeable from the recursive group up front).
Comment 2 Joseph Marques 2008-11-09 17:11:13 EST
rev1944 - add "suppress recursive results" filter to the table that displays resource members for a resource group; 
Comment 3 Jeff Weiss 2008-12-10 15:50:39 EST
Looks good, tested on windows2003, oracle, rev2123.
Comment 4 Red Hat Bugzilla 2009-11-10 16:15:13 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-707
This bug is related to RHQ-1091

Note You need to log in before you can comment on or make changes to this bug.