Bug 536377 - (RHQ-732) Proxy should have an Enable/Disable override for proxy settings.
Proxy should have an Enable/Disable override for proxy settings.
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.1pre
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-13 15:30 EDT by Corey Welton
Modified: 2014-05-02 13:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 13:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2008-08-13 15:30:00 EDT
Steps to repro:
1. Login to JON
2. Content Sources  >  JBoss Patch Content Source > Edit
3. Expand the Proxy Settings windowshade
4. Begin to make various changes to the fields; click the "Unset" checkbox next to the fields and note that the text disappears.
5. Pretend for a second that you're an end user and temporarily want to disable proxy on said channel.

Expected results:
User would be able to check an overriding field akin to : 
Proxy  (*) Enabled   ( ) Disabled 

...which would enable/gray out these other proxy field values, preserving the settings that are already in there.

Current results:
It is cumbersome if user wants to enable/disable proxy -- for example, network troubleshooting, etc. -- since the proxy values are wiped out each time.

This is not too different from the way that Firefox and IE handle their proxy usage -- if proxy is disabled, the values remain in the UI and config files, but are unused/inaccessible.

Comment 1 Joseph Marques 2008-08-13 21:38:26 EDT
i'm accepting this jira, although the request may be a bit more work than we're realistically willing to do (for 1.1).  presently the generic config UI component was written as unset being a UI-only concept.  if some property is unset, the null value is persisted for that property.  if we wanted to support this, it would require a domain model change so that properties can store values that we would *want* to use, but don't actually use.  this way, when the unset control is clicked in the UI, it would be possible for the config UI component to keep those values (but gray the input out / make the input read-only), and then persist the property values.
Comment 2 Red Hat Bugzilla 2009-11-10 16:15:48 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-732

Note You need to log in before you can comment on or make changes to this bug.