Bug 536409 - (RHQ-761) Packages > New > Upload New Package silent accepts jar files as CPs.
Packages > New > Upload New Package silent accepts jar files as CPs.
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Web Services (Show other bugs)
1.1pre
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
:
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2008-08-27 10:22 EDT by Corey Welton
Modified: 2014-05-02 13:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 13:53:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2008-08-27 10:22:00 EDT
1. Login to JON instance.
2. navigate to RHQ AS server resource
3. Packages > New; Upload New Package
4. Specify "Cumulative Patch" as the "Type", but upload a .jar
5. Attempt to deploy.

Expected results:
* User is not able to upload jar as a CP, and/or
* Deploy attempt should explicitly fail immediately.

Current results:
* User able to upload jar as CP
* Deployment attempt continues, before eventually timing out
Comment 1 Joseph Marques 2008-08-28 01:33:46 EDT
lowering this to minor since it would be nice to prevent this, but pragmatically speaking i think it's realistic to expect users to use the web app correctly.  i suppose an argument could be made that they might have meant to choose jar, but didn't switch off of the CP choice.  accepting this.
Comment 2 Corey Welton 2009-02-26 12:34:27 EST
I'm not sure there's a way to delete these files either, once they are uploaded, but (perhaps) depending on impl for this issue, that might not be as big a deal.

The structure of a CP is a .zip archive that contains an 'install-process.xml' file, as well as the directories and contents of the patches. 

I wouldn't expect this part of the ui to validate the CP itself -- that would be the task of the CP processor.  Upload process could simply verify that we've got a .zip, and (maybe) whether or not it contains the xml file.    
Comment 3 Red Hat Bugzilla 2009-11-10 16:16:25 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-761

Note You need to log in before you can comment on or make changes to this bug.