Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 53644 - 440GX: Installer hangs when loading aic7xxx module, worked around that with boot image, but hangs on reboot
440GX: Installer hangs when loading aic7xxx module, worked around that with b...
Status: CLOSED DUPLICATE of bug 79752
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 15:15 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-13 15:15:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
Followed the thread on the aic7xxx module hanging up on L440GX+ boards, 
which is what we have.  I am able to install with the boot images 
provided, but when I reboot, it hangs with the same thing rparish was 
getting and then the screen goes black, right before I do a hard reboot on 
it, the screen will come back, but too quick before it goes off again, so 
I can't get the end of the error messages.

Phone support asked me to start a new bug report with the error messages I 
can get, they are as follows..

<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 1, 
lun 
0 0x12 00 00 00 ff 00
<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 1, 
lun 
0 0x12 00 00 00 ff 00
<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 2, 
lun 
0 0x12 00 00 00 ff 00
<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 2, 
lun 
0 0x12 00 00 00 ff 00
<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 3, 
lun 
0 0x12 00 00 00 ff 00

so on.. until id 15 then switches to the second scsi chaing scsi1 id0 and 
so on 
until id15
then 
<4>attached scsi disk sda at scsi0, channel 0, id 0, lun 0
<4>scsi : aborting command due to timeout : pid 0, scsi0, channel 0, id 0, 
lun0 
0x00 00 00 00 00 00
<6>(scsi0:0:0:0) SCSISIGI 0xa4, SEQADDR 0x162, SSTAT0 0x0, SSTAT1 0x2
<6>(scsi0:0:0:0) SG_CACHEPTR 0x2, SSTAT2 0x0, STCNT 0x0
<4>SCSI host 0 abort (pid 0) timed out - resetting
<4>SCSI bus is being reset for host 0 channel 0.
<4>SCSI host 0 abort (pid 0) timed out - resetting
<4>SCSI bus is being reset for host 0 channel 0.
<4>(scsi0:0:0:0) Device reset, Message buffer in use
<4>SCSI host 0 channel 0 reset (pid 0) timed out - trying harder...

and so on.. keeps looping.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install with boot images
2. reboot after install
3.
	

Actual Results:  hangs and screen goes black

Expected Results:  reboot to login

Additional info:
Comment 1 Arjan van de Ven 2001-09-14 04:20:56 EDT
the "apic" line is still needed after the installation, unless you install the
SMP kernel.
Comment 2 Need Real Name 2001-09-14 11:00:04 EDT
Is that done using the kernel arguments line during the installation process?  
I am unable to logon at all to configure any of the startup scripts.
Comment 3 Arjan van de Ven 2001-09-14 11:41:49 EDT
You're supposed to type at at the lilo prompt (eg hit 'x' at the graphical lilo
screen and type "linux apic")
Comment 4 Need Real Name 2001-09-19 09:09:00 EDT
The loader won't get to the graphical screen at all.  It hangs before I am 
given the chance to enter the option command.
Comment 5 Arjan van de Ven 2001-09-19 09:11:49 EDT
No not the "linux GDM login screen" but the Lilo screen where you can select
kernels to boot...
Comment 6 Need Real Name 2001-09-20 17:37:44 EDT
Sorry about the mix-up there.  We have gone back to 6.2 on that web server for 
the time being, but I may try that out tomarrow afternoon.  I do have a few 
questions on this method, however.  Is it possible to boot with the apic option 
at the lilo: prompt without physically sitting at the box when it reboots, 
perhaps with a startup script of some type.  Also, how has the progress gone 
with intel on this issue?  It seems once the BIOS for this box has been 
updated, that the proper routing table will be used and the apic workaround 
will no longer be needed.  Am I even close on this?

Thanks
Comment 7 Arjan van de Ven 2001-09-21 04:59:31 EDT
You can add the "apic" option as default to the lilo.conf by using an "append"
line.
Comment 8 David Low 2001-09-27 13:47:44 EDT
The behavior on my install has been the same as tswarm's.  So, if I may, I 
shall add to this effort.

How can the "apic" option be added to lilo.conf, if the system can not reboot?

Is there a boot image with the fix (as in the install image) that would allow 
the entry of "apic", or is there a means of replacing the installed kernel with 
a fixed kernel?  (Obviously, when I try the fixed boot image, it goes into the 
install procedure and that does me no good, and a rescue disk will be based on 
the newly installed kernel.)

Thank you.
Comment 9 Need Real Name 2002-09-09 16:56:24 EDT
I'm having the install problem on an L440GX+, installing RHat 7.2.  Do we know
if the problem has a 7.2 workaround (like the modified boot images) or is fixed
in 7.3?
Comment 10 Arjan van de Ven 2002-09-09 17:04:04 EDT
7.2 and 7.3 have a blacklist for broken bioses; if you have a bios not in the
list you need to use the apic option and make sure we get your bios info for
adding to the list.
Comment 11 Need Real Name 2002-10-17 14:23:54 EDT
I have exactly the same looping problem as tswarm with Red-hat 8.0
I have the same mother board with one processor with the latest BIOS and SCSI 
BIOS Update.
When I installed it I choose 'linux noprobe apic' and then I choose the 'OLD 
APIC7xxx ....' driver, after that I choose to install the SMP kernel to.
The installation process went right but when it boots with 'linux' it stops 
with this message:
Serial driver 5.05c (2001-04-08) with MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI 
ISPNP enabled

and with the 'linux_up', it stays looping....

I really don't know whta to do :|, Is ther any img file whixh updates the 
AIC7xxx driver? 

Please help
Comment 12 Hugh Conner 2003-02-10 05:40:34 EST
I'm getting something very similar to htaveres under Redhat 7.3. The system was
working fine using the 2.4.18-5smp kernel, but I can't get either 2.4.18-18 or
2.4.18-24 to work. The non smp kernel still gives the scsi timeouts and the smp
kernel gets as far as printing

VFS: Diskquotas version dquot_6.5.0 initialized

or sometimes one line further

pty: 2048 Unix98 ptys configured

which is the line before the Serial driver one mentioned by htaveres

I've gone back to 2.4.18-5 for the time being, but I really want to upgrade to 
the latest patch. Is there any way of making the newer kernels work with this 
system?
Comment 13 Alan Cox 2003-06-08 07:37:20 EDT

*** This bug has been marked as a duplicate of 79752 ***
Comment 14 Red Hat Bugzilla 2006-02-21 13:48:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.