Bug 5365 - linuxconf hook in ifup-routes doesn't support all options
linuxconf hook in ifup-routes doesn't support all options
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-25 15:17 EDT by Donald Greer
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:30:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Greer 1999-09-25 15:17:49 EDT
I am configuring a system that will have a default route
to the local lan, static routes to all local networks, but
will also have a dialup account as a backup.
  To make this work, I need to have a default route on eth0
with one metric (5) and one on ppp0 with another metric (2)
so that when the ppp0 comes up, packets to non-local
networks go that direction.
  I can add local networks in /etc/sysconfig/static-routes
and that works fine.but to get a metric on multiple default
routes, I have to add those default routes to the
static-routes table.  Apparently, if linuxconf is present
(and the appropriate ncurses library) you use "linuxconf
--hint route "$1"" (where $1 is the interface).  Linuxconf
ignores the "metric X" statement, so I can't set metrics.
  I can add the routes as "eth0 net 0.0.0.0 netmask 0.0.0.0
metric 5" but it doesn't make a difference.
  I've worked around it by hacking ifup-routes to disregard
linuxconf, but that's certainly not the optimal solution.
  Please add "metric" support to linuxconf if possible (or
add it to the wish list for the development team).  Also,
please allow me to override linuxconf for routing (say with
a line in static-routes "linuxconf no" that gets checked
before checking for linuxconf).
  Thanks.
  Don
Comment 1 Michael K. Johnson 1999-11-18 18:57:59 EST
Added Jacques to the CC line to prime a discussion about adding metrics...
Comment 2 Brent Fox 2002-06-05 00:12:11 EDT
Closing since we don't ship linuxconf anymore.

Note You need to log in before you can comment on or make changes to this bug.