Bug 53651 - Anaconda update-disk-20001009.img Crashes During Linux Install
Anaconda update-disk-20001009.img Crashes During Linux Install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 19:21 EDT by dt250195
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 22:39:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dt250195 2001-09-13 19:21:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
I'm having various anaconda problems so I downloaded the update-disk-
20001009.img file and created a disk using this image file. I then 
ran "linux updates text" from the boot prompt booting from disk.  It 
prompts me to insert the update disk and when it starts running  anaconda 
it crashes with two errors.
       

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download update-disk-20001009.img
2.Create an update disk the same way as a boot disk
(run rawrite and enter the image location, etc .... )
3.Boot linux from disk and at boot prompt type "linux updates text"
4.When told to put in the updates disk put in the disk you created in 
steps 1 and 2.
5.This disk will start running anaconda and then crash the system	

Actual Results:  ERRORS:
Traceback (innermost last):
     File "/usr/bin/anaconda", line 517, in? extraModules = extraModules)
     File "/tmp/updates/todo.py", line 344, in__init__log.open (serial, 
reconfigOnly, test) TypeError: not enough arguments; expected 5, got 4 
install exited abnormally
sending termination signals...done 
sending kill signal...done
disabling swap...
unmounting filesystems... /mnt/runtime /mnt/source umount failed ()
/dev/pts/proc
you may safely reboot your system
 


Expected Results:  I should have been able to move on with installation 
but it sends a termination signal and halts everything.

Additional info:

     I tried new disks, downloading the file a few times etc.. Still the 
same error.  I found some anaconda image fix links on your ftp page but 
all the permissions to the links have been blocked so I can't download and 
try anything.  I think there was something in a fisher folder but I can't 
download any of it, not sure why.
Comment 1 Brent Fox 2001-09-14 11:56:34 EDT
Errr...the update-disk-20001009.img file is an errata release for 7.0, so trying
to use it with 7.1 (which is what this bug report lists as the version you are
using) is not going to work.  There hasn't been an anaconda errata for Red Hat
Linux 7.1.  I don't understand what you're trying to do.  A better explaination
of the anaconda problems you were having before trying the update disk would be
helpful.

Comment 2 dt250195 2001-09-17 22:02:26 EDT
These are the anaconda problems I was having before trying the update disk (Red 
Hat 7.1):

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, 
in run
    rc = apply (step[1](), step[2])
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
if todo.doInstall ():
  File "/usr/lib/anaconda/todo.py", line 1547, in doInstall
self.instCallback, p)
  File "/usr/lib/anaconda/todo.py", line 1298, in instCallback
self.rpmFD = os.open(fn, os.O_RDONLY) OS
Error: [Errno 2] No such file or directory: '/mnt/source/RedHat/RPMS/setup-
2.3.4-1.noarch.rpm'
Local variables in innermost frame:
fn: /mnt/source/RedHat/RPMS/setup-2.3.4-1.noarch.rpm
total: 0
self: <todo.ToDo instance at 8221508>
h: <header object at 88252b0>
amount: 0
intf: <text.InstallProgressWindow instance at 8e93e70>
what: 2
ToDo object:(itodoToDop1(dp2S'method'p3(iimageCdromInstallMethodp4
(dp5S'progressWindow'p6
<failed>


Comment 3 Brent Fox 2001-09-18 10:03:12 EDT
Ok, the installer is unable to read some of the packages from the cd.  This
usually means that the cdrom media is damaged somehow.  When the install
crashes, try pressing <Ctrl><Alt><F4> and see if there are any error messages
there related to the cdrom drive.
Comment 4 dt250195 2001-09-18 22:39:08 EDT
     Ok there were error messages about the cdrom.  I put a different cdrom in 
and had no problems loading.  No need to respond to this comment.  Thankx



 

Comment 5 Brent Fox 2001-09-19 10:36:49 EDT
Ok.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.