Bug 536522 - (RHQ-863) Unlicensed instances should not appear as "NORMAL" in HA server list
Unlicensed instances should not appear as "NORMAL" in HA server list
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.1pre
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Corey Welton
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-19 10:06 EDT by Corey Welton
Modified: 2011-03-25 15:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-25 15:36:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2008-09-19 10:06:00 EDT
Instances of the server which do not have a license file installed are obviously not usable -- but show up as status "NORMAL" in server list

Steps
1. Install main server ('rhq1') and assure it is functional.
2. Install second instance ('rhq2') but do not upload the license file.
3. On rhq1, 'Administration > List Servers'
4. View results.

Expected results: 
Some indication that this box is otherwise not actually usable within the cloud since it is not licensed

Curent results:
Status of "NORMAL"

Other notes:
I haven't yet attempted to have an agent registered to this server in HA despite its unlicensed status.  That said, we still probably shouldn't show it as NORMAL if it is not actually usable in the first place.

Comment 1 Corey Welton 2008-10-02 11:28:10 EDT
Upon further consideration, since systems can apparently be registered through the non-licensed server, and this is a known functionality, perhaps this is not as much an issue.

However -- I still think "NORMAL" should be replaced, since it is still not a valid state.  Although agents can be registered, the server UI cannot otherwise be used.  Maybe a state of "UNREGISTERED" or "UNLICENSED", or something similar, would be valid.
Comment 2 Red Hat Bugzilla 2009-11-10 16:18:27 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-863
Comment 3 wes hayutin 2010-02-16 12:08:14 EST
mass add of key word FutureFeature to help track
Comment 5 John Mazzitelli 2011-03-25 15:36:57 EDT
RHQ server no longer requires license files. this issue is now obsolete.

Note You need to log in before you can comment on or make changes to this bug.