Bug 536523 - (RHQ-864) On the Metric Data subtab, for data that is not even being collected, shows zeros instead of n/a or blank
On the Metric Data subtab, for data that is not even being collected, shows z...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.1pre
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2008-09-19 10:27 EDT by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-15 17:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2008-09-19 10:27:00 EDT
<joseph> jweiss, probably because avg(col) in sql will always give a real result back
<jweiss> joseph: even if there are no rows?
<joseph> yup
<jweiss> seems like it should give NaN or something

I think maybe update update the code+sql to check for zero rows first, and then change the display to NaN or or n/a or some non-number.  
Comment 1 Red Hat Bugzilla 2009-11-10 16:18:28 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-864
Comment 2 wes hayutin 2010-02-16 11:53:36 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 11:58:52 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Joseph Marques 2010-10-05 11:42:18 EDT
can't determine this because we don't know the difference between "not currently collecting" and "never have collected" - that discerning info is not stored anywhere.  the best we can do is show what we think the current numeric value is, but annotate some rows with "not currently collecting this metric"
Comment 5 Jeff Weiss 2010-10-05 11:49:28 EDT
I don't understand.  The problem was that even for metrics where not a single row of data was EVER collected, the stats would still have numbers in them.

How can the code not know there are zero rows?  It has to calculate the average.

Note You need to log in before you can comment on or make changes to this bug.