Bug 536555 - (RHQ-893) Installer should check for existing, external db connections prior to commencing install.
Installer should check for existing, external db connections prior to commenc...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Installer (Show other bugs)
1.1pre
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 11:11 EDT by Corey Welton
Modified: 2013-12-07 11:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 11:01:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2008-09-25 11:11:00 EDT
1. Install RHQ, using HA, on two different servers, A and B
2. Attempt to reinstall an RHQ instance on server A.
3. View results:

Current results:
Installer hangs indefinitely due to the fact that another system (server B) is still using db.

Expected results
* This is mostly user error.  However, it would certainly be a nice addition to the installer to be able to determine if external db connections are being made to the db in question, and toss up a big ol' warning, telling the user that this is the case -- and perhaps reminding them to disable all other instances prior to continuing.

Something like
(!) Warning:  It appears that there are other active connections to this database.  Please assure that all other RHQ instances using this database have been shutdown, prior to continuing.


Other notes:
* I don't really expect this to be completed for 1.1.  I'm willing to lower priority, however, if RHQ-892 is implemented as a docs fix.


Comment 1 Jay Shaughnessy 2008-09-25 11:52:45 EDT
It would be easy, I think, to have the install fail if any registered server in the DB was in NORMAL operation mode. Throwing a decent exception reminding the user to shut down all instances.  Although, it's not clear to me why the install hangs.
Comment 2 Red Hat Bugzilla 2009-11-10 16:19:06 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-893
Comment 3 wes hayutin 2010-02-16 12:08:43 EST
mass add of key word FutureFeature to help track
Comment 4 Corey Welton 2010-10-05 09:39:42 EDT
triaged 30-sep
Comment 5 Heiko W. Rupp 2013-12-07 11:01:42 EST
Closing as outdated.

Note You need to log in before you can comment on or make changes to this bug.