This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 536577 - (RHQ-912) JVM remoting - errors appear in agent when jvm is shut down
JVM remoting - errors appear in agent when jvm is shut down
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
1.1pre
All All
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: rhq_triage
  Show dependency treegraph
 
Reported: 2008-09-30 16:39 EDT by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
windows, rev1653, jrockit 1.5.0 jvm
Last Closed: 2014-05-15 17:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2008-09-30 16:39:00 EDT
To reproduce -

Run and discover jconsole as specified in the description of the linked jira.  
Close the jconsole.  Look at your agent's output, I get:

C:\jon\jon-agent-2.1.0-SNAPSHOT\bin>rhq-agent.bat
Loading script environment from rhq-agent-env.bat...
RHQ 1.1.0-SNAPSHOT (Tue Sep 30 05:11:10 EDT 2008)
sending> Sep 30, 2008 4:33:37 PM ClientCommunicatorAdmin restart
WARNING: Failed to restart: java.io.IOException: Failed to get a RMI stub: javax.naming.ServiceUnavailableException [Root exception
is java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:
        java.net.ConnectException: Connection refused: connect]
Sep 30, 2008 4:33:38 PM RMIConnector RMIClientCommunicatorAdmin-doStop
WARNING: Failed to call the method close():java.rmi.ConnectException: Connection refused to host: 10.18.0.79; nested exception is:
        java.net.ConnectException: Connection refused: connect
Sep 30, 2008 4:33:38 PM ClientCommunicatorAdmin Checker-run
WARNING: Failed to check connection: java.net.ConnectException: Connection refused: connect
Sep 30, 2008 4:33:38 PM ClientCommunicatorAdmin Checker-run
WARNING: stopping

Also, I'm not sure if this is related but sometimes the resource won't turn green again when I restart jconsole (not 100% reproduceable)
Comment 1 John Mazzitelli 2008-12-13 00:44:27 EST
"Run and discover jconsole as specified in the description of the linked jira. "

there is no linked jira.

I don't understand what you are doing here.  jconsole?  that monitors MBeans - I'm not sure if you are sayign you are trying to get the agent to monitor jconsole itself.

Need more info - this smells like an artificial problem that no one will encounter, unless I'm missing something.
Comment 2 Jeff Weiss 2008-12-15 07:33:16 EST
Added link that I apparently forgot.  
Comment 3 Jay Shaughnessy 2009-03-03 14:23:30 EST
I've seen this.  It may be related to JMX plugin and the RMI connections involved.  Mazz found:  

  http://forums.sun.com/thread.jspa?threadID=5283213

which may be related.
Comment 4 Red Hat Bugzilla 2009-11-10 16:19:29 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-912
This bug relates to RHQ-829
Comment 5 wes hayutin 2010-02-16 11:56:15 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 6 wes hayutin 2010-02-16 12:01:24 EST
making sure we're not missing any bugs in rhq_triage
Comment 7 Jay Shaughnessy 2014-05-15 17:31:45 EDT
This has not been seen in a long time, and is likely n/a due to component upgrades.

Note You need to log in before you can comment on or make changes to this bug.