Bug 53658 - Install failes under mutilple circumstances, hard crash....
Install failes under mutilple circumstances, hard crash....
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-09-14 03:41 EDT by gehan gehale
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-15 00:37:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description gehan gehale 2001-09-14 03:41:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
(long and discriptive)
I own a dell dimention V350. A few months ago I installed RH 5.1 on it and 
have been useing it ever since. 
I never have had a crash on install or in use, nor any problems with it 
what so ever.. I figured the upgrade 
to 7.1 would be just as pleasent.. Boy was I wrong..
I've installed 5.1 a few different times here and there changeing 
different things each time but every time I 
start the install it's by booting a dos disk . CD ing to D:\dosutils and 
run autoboot.. flawless install everytime...

I thought my many failed install and upgrade attempts at 7.1 might be 
because of the dos boot disk so I made a linux boot 
disk from the redhat 7.1 cd useing - dd /images/bootdisk.img /dev/fd0 and 
it contains the files 
 and vmlinuz
When I try to boot from this disk I get about 15 messeges that scroll 
saying -
Unknown keyword in syslinux.cfg  
except the last line which says 
Could not find kernal image: linux  
---anything I type in resuts in "could not find kernal image:  (something 
i typed) except when I type vmlinuz
that get's me "Boot failed please change disk and try again" when I remove 
the disk and press enter I get a Lilo: 
prompt which boots to linux 5.1 just fine..

Ok so now I go back to my old way which I use to install 5.1 I put the 7.1 
cd in, boot with dos floppy, go to 
d:\dosutils\autoboot, which boots the 7.1 install program just fine..
Starting anaconda
Probing mouse
Starting X
GUI install program starts

English --> next

mode Generic Keyboard 105 - intel pc
layout US English
dead keys enabled --> next

generic 2 button
simulate 3 button enabled -->next

customize packages to install (yes)

It gives me the choice of putting it on / /hda1 or /dsc /hda2
I click to create a new swap file on /hda1 which has 3177MB free -->next

About 60% though creating swap space the system crashes hard. The computer 
stops makeing noise, 
progress bar stops moveing across the screen, and a bright green bar 
appears across the very top of my 
monitor(not a linux problem, the green line across the top of my monitor 
indicates a hard system crash when I was useing windows too)

So I power down and reboot to dos and re start d:\dosutils\autoboot

I select all the same options but this time when I select upgrade I get an 
error saying that my drive 
was not cleanly unmounted to reboot, so I take out the dos disk, reboot to 
5.1, logon as root, issue a shutdown -h now, power down...

Insert dos disk start autoboot with same options only when I get to the 
swap warning I chose to put it 
on /dsc /hda2 which has 2811 MB free instead of / /hda1... System crashes 
here to about 35 - 40 % through 
swap fomatting, same deal.. boot 5.1, issue shutdown, boot dos, autoboot, 
same options....

Now when I get to the swap warning I choose to skip the swap upgrade 

reading package information --- finding packages to upgrade --- checking 
total size 1330M  --> next

Make bootdisk (yes)
Install lilo (yes)
Put on MBR (yes)
Put on /dev/hda1 (no)
Use liner mode with no kernal peramitors (yes)
Partition is /dev/hda1
use default image (yes)
Boot label: linux  --> next

checking dependencies -- warning dependincies are needed -- I 
choose "install packages to satisfy 
dependencies -->next

Transfering install image to hard drive - done
Prepareing to install (539 packages, 1330M)
Installing Packages...

I see the packages installing.. on the 14th package Hard crash, same as 
Package installing when it froze was glibc-2.2.2-10
          num    size   time
completed 14     123M    3:28

knowing that I'm going to have to go issue a shutdown command I remove the 
dos boot disk
before I reboot... when lilo tries to boot 5.1 I get an error..

An error has occured during file system check
Dropping to shell, after the system will reboot
supply root password for maintenace

I give root password and go to /tmp dir..
I cat the upgrade.log contents are:
upgrading backgrounds
upgrading gal.
upgrading ghostscript fonts
upgrading glibc-common
upgrading gnome audio
upgrading gnome audio extra
upgrading gnome user guide
upgrading index.html
upgrading mailcap
upgrading redhat logos
upgrading redhat releace
upgrading setup
/ect/services saved as /ect/services.rpmsave

can not remove /mnt/sysimage/usr/man/mann - dir not empty
can not remove /mnt/sysimage/usr/man/man9 - dir not empty
can not remove /mnt/sysimage/usr/man/man8 - dir not empty
can not remove /mnt/sysimage/usr/man/man7 - dir not empty
can not remove /mnt/sysimage/usr/man/man6 - dir not empty
can not remove /mnt/sysimage/usr/man/man5 - dir not empty
can not remove /mnt/sysimage/usr/man/man4 - dir not empty
can not remove /mnt/sysimage/usr/man/man3 - dir not empty
can not remove /mnt/sysimage/usr/man/man2 - dir not empty
can not remove /mnt/sysimage/usr/man/man1 - dir not empty

then one line of hyrogilphics with this is the middle - '9/mnt/sysimage/ - 
one more line of gook
end of file

 So now I've rebooted and started the install process of 5.1 re formating 
drives from scratch..
that should be done by now and I will attemt to install 7.1 selecting 
custom instead of upgrade.. 
I will post though results later (supected result: more crashes)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.boot dos floppy, cd to D:\dosutils\autoboot
2.Intall Upgrade option
3. upgrade swap or don't upgrade swap

Actual Results:  Hard System Crash

Expected Results:  Program should have installed like 5.1 always does...

Additional info:

Please if you read this reply. At least something to know it's being 
looked in to....
Comment 1 gehan gehale 2001-09-15 00:37:05 EDT
Closeing bug.. I reformated drive and installed 5.1 then went and installed 7.1 
as a cutom install instead of upgrade.. It failed once in while formating 
drive, once during package install.. after reformatting adn reinstalling 
several times on the 4th time or so I unselected all the packages and chose not 
to format the drives and it still had 224 packages which is the smallist I 
could get and it finally got 100% thought package instll with out crashing.. 
Now I'm just going theough the process of installing the packages I wanted 
in... netscape, kde, xwindows.. ect.... 
 BTW... when I package has a depencdency how do I find out what package 
contains that file? For instance when I try to install netscape it tells me is 
has a dependecy to libstdc++-lib6.1-1.so.2 ... I have installed the libstdc++ 
package but still no go.. where do I find libstdc++-lib6.1-1.so.2? if anyone 
knows please mail me at gehang@yahoo.com

P.S. Is there any forums here where I can post general questions such as the 
one above? I seached the site and couldn't find them but I remember seeing them 
before I thought??

thanks again..
gehan gehale

Note You need to log in before you can comment on or make changes to this bug.