Bug 536597 - (RHQ-930) Purge All button in partition event page should have a confirmation dialog
Purge All button in partition event page should have a confirmation dialog
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.1pre
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement, SubBug
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2008-10-03 09:31 EDT by Jeff Weiss
Modified: 2014-11-09 17:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
HA install, rev1653
Last Closed: 2014-05-15 17:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2008-10-03 09:31:00 EDT
Go to the Partition Events page (after there are many events on the page - can generate these by putting servers in/out of MM), filter the list by the Type Filter dropdown.  The list will be filtered.  Now click Purge All.   All the events disappear as expected.

Now set the Type Filter to "All".  You would expect to see all the events except the ones you just deleted.  The actual behavior is that Purge All purges all the events regardless of the filter.  Since it's easy to misinterpret what Purge All does, how about a confirm dialog "Purge all events (even those not currently displayed)?" or something along those lines.
Comment 1 Red Hat Bugzilla 2009-11-10 16:19:52 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-930
Comment 2 wes hayutin 2010-02-16 11:53:46 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 11:59:00 EST
making sure we're not missing any bugs in rhq_triage
Comment 4 Rajan Timaniya 2010-10-29 05:08:24 EDT
Tested on RHQ-Master build #526

Steps:
1) Install RHQ server and agent
2) Navigate to 'Administrator' -> 'Topology - Partition Event'
3) Click on 'Purge All' button 

Observation:
There is no confirmation dialog for purge all in partition event. There should have a confirmation dialog.
Comment 5 Jay Shaughnessy 2014-05-15 17:36:09 EDT
This is done.

Note You need to log in before you can comment on or make changes to this bug.