Bug 536613 (RHQ-945) - JBoss AS connection properties caching
Summary: JBoss AS connection properties caching
Keywords:
Status: CLOSED DUPLICATE of bug 534213
Alias: RHQ-945
Product: RHQ Project
Classification: Other
Component: Plugins
Version: unspecified
Hardware: All
OS: All
medium
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact:
URL: http://jira.rhq-project.org/browse/RH...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-10-06 13:03 UTC by fmatar
Modified: 2009-11-11 17:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Fedora Core 9 Postgres JBoss AS -4.2.2.GA
Last Closed:


Attachments (Terms of Use)

Description fmatar 2008-10-06 13:03:00 UTC
JBoss AS connection properties are being cached, this issue could relate to RHQ-501.

Steps to reproduce:
1. Configure a secured installation of JBoss AS
2. Copy the secured installation as several other installations, In my case I created 4 instances: dev01, dev02, dev03 and dev04. Note that the usernames / passwords are the same for the all the server configurations.
3. Start the four instances of JBoss AS with different IP binding (use the -b switch) e.g: 
     ./run.sh -c dev01 -b 192.168.0.101
     ./run.sh -c dev02 -b 192.168.0.102
     ./run.sh -c dev03 -b 192.168.0.103
     ./run.sh -c dev04 -b 192.168.0.104
4. run discovery -f on the agent to discovery the 4 running instances 
5. Import the instances into your inventory. Over here all the instances will be marked as red since the connection properties are not properly set. 
6. Update the connection properties of one of the JBoss AS instances 

Go back to your inventory, you'll see that all the server instances are marked as green and properly imported with the credentials of the jmx-console set.

Comment 1 Joseph Marques 2008-11-05 01:59:19 UTC
Fady, good find, but this is an issue with your customer JBossAS plugin, not the RHQ platform or one of the RHQ core platform plugins.  You can track the progress of this issue here -- https://jira.jboss.org/jira/browse/JOPR-9

Comment 2 Jeff Weiss 2008-11-05 14:38:51 UTC
See also JOPR-9

Comment 3 Red Hat Bugzilla 2009-11-10 21:20:08 UTC
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-945
This bug duplicates RHQ-1030
This bug relates to RHQ-501
This bug was marked DUPLICATE in the database but has no duplicate of bug id.

Comment 4 David Lawrence 2009-11-11 17:30:40 UTC

*** This bug has been marked as a duplicate of bug 534213 ***


Note You need to log in before you can comment on or make changes to this bug.