Bug 536689 - libnetfilter_conntrack update (0.0.100) for fc11 conflicts with iptstate dependencies
Summary: libnetfilter_conntrack update (0.0.100) for fc11 conflicts with iptstate depe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libnetfilter_conntrack
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Paul P Komkoff Jr
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 536695 536744 536790 536904 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-10 23:23 UTC by Philip Prindeville
Modified: 2009-11-21 13:17 UTC (History)
23 users (show)

Fixed In Version: 2.2.2-3.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-12 00:50:11 UTC


Attachments (Terms of Use)

Description Philip Prindeville 2009-11-10 23:23:32 UTC
Description of problem:

Tried to run "yum update" but it failed:

[philipp@builder ~]$ sudo yum update
Loaded plugins: dellsysidplugin2, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libnetfilter_conntrack.so.1()(64bit) for package: iptstate-2.2.1-5.fc11.x86_64
---> Package libnetfilter_conntrack.x86_64 0:0.0.100-1.fc11 set to be updated
--> Finished Dependency Resolution
iptstate-2.2.1-5.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: libnetfilter_conntrack.so.1()(64bit) is needed by package iptstate-2.2.1-5.fc11.x86_64 (installed)
Error: Missing Dependency: libnetfilter_conntrack.so.1()(64bit) is needed by package iptstate-2.2.1-5.fc11.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[philipp@builder ~]$ 

So the update pushes out libnetfilter_conntrack.so.3.0.0, but iptstate still requires libnetfilter_conntrack.so.1.0.0 ...

Someone needs to relink and republish iptstate.


Version-Release number of selected component (if applicable):

libnetfilter_conntrack-0.0.100-1.fc11.x86_64


How reproducible:

[philipp@builder ~]$ rpm -q --filesbypkg -p http://mirrors.cat.pdx.edu/fedora/linux/updates/11/x86_64/libnetfilter_conntrack-0.0.100-1.fc11.x86_64.rpm
libnetfilter_conntrack    /usr/lib64/libnetfilter_conntrack.so.3
libnetfilter_conntrack    /usr/lib64/libnetfilter_conntrack.so.3.0.0
libnetfilter_conntrack    /usr/share/doc/libnetfilter_conntrack-0.0.100
libnetfilter_conntrack    /usr/share/doc/libnetfilter_conntrack-0.0.100/COPYING
[philipp@builder ~]$ 
[philipp@builder ~]$ rpm -q --requires iptstate
iptables  
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libc.so.6(GLIBC_2.4)(64bit)  
libgcc_s.so.1()(64bit)  
libgcc_s.so.1(GCC_3.0)(64bit)  
libm.so.6()(64bit)  
libm.so.6(GLIBC_2.2.5)(64bit)  
libncurses.so.5()(64bit)  
libnetfilter_conntrack.so.1()(64bit)  
libstdc++.so.6()(64bit)  
libstdc++.so.6(CXXABI_1.3)(64bit)  
libstdc++.so.6(GLIBCXX_3.4)(64bit)  
libstdc++.so.6(GLIBCXX_3.4.11)(64bit)  
libstdc++.so.6(GLIBCXX_3.4.9)(64bit)  
libtinfo.so.5()(64bit)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
[philipp@builder ~]$ 



Steps to Reproduce:
1. above
2.
3.
  
Actual results:

iptstate requires libnetfilter_conntrack.so.1.0.0

Expected results:

ipstate should require libnetfilter_conntrack.so.3.0.0


Additional info:

none

Comment 1 chenhuan.gt 2009-11-11 03:32:21 UTC
F11 x86 too

Comment 2 David Juran 2009-11-11 06:37:52 UTC
Also breaks iptstate on Fedora 10

Comment 3 Thomas Woerner 2009-11-11 08:19:43 UTC
*** Bug 536695 has been marked as a duplicate of this bug. ***

Comment 4 Paul P Komkoff Jr 2009-11-11 09:25:14 UTC
I broke it, I gonna fix it...

Comment 5 Fedora Update System 2009-11-11 09:43:09 UTC
iptstate-2.2.2-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/iptstate-2.2.2-3.fc10

Comment 6 Fedora Update System 2009-11-11 09:43:16 UTC
iptstate-2.2.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/iptstate-2.2.2-3.fc11

Comment 7 Michael Schwendt 2009-11-11 11:16:48 UTC
*** Bug 536744 has been marked as a duplicate of this bug. ***

Comment 8 Michael Schwendt 2009-11-11 11:18:14 UTC
Also note that you can push multiple packages within a single ticket in bodhi.

Comment 9 Bradley 2009-11-11 11:56:00 UTC
*** Bug 536790 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2009-11-12 00:50:05 UTC
iptstate-2.2.2-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-11-12 00:56:42 UTC
iptstate-2.2.2-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Thomas Woerner 2009-11-12 11:13:47 UTC
*** Bug 536904 has been marked as a duplicate of this bug. ***

Comment 13 Peter Backes 2009-11-18 02:13:05 UTC
I just upgraded to F12 and it has the same problem:

Error: Missing Dependency: libnetfilter_conntrack.so.1 is needed by package iptstate-2.2.1-6.fc12.i686 (fedora)

even happens with --enablerepo=updates-testing

Comment 14 Mitchell Berger 2009-11-18 02:31:43 UTC
The problem's fixed in F10 and F11.  It looks like iptstate-2.2.2-3.fc12
was built in Koji beyond the point where it automatically got into F12,
and Thomas needs to submit an update request to push it out.

Comment 15 Peter Backes 2009-11-18 03:44:15 UTC
(In reply to comment #14)
> The problem's fixed in F10 and F11.  It looks like iptstate-2.2.2-3.fc12
> was built in Koji beyond the point where it automatically got into F12,
> and Thomas needs to submit an update request to push it out.  

Nope, the most recent F12 build is still has the problem (F10 and F11 ones are okay):

rpm -qp --requires http://kojipkgs.fedoraproject.org/packages/iptstate/2.2.2/3.fc10/i386/iptstate-2.2.2-3.fc10.i386.rpm http://kojipkgs.fedoraproject.org/packages/iptstate/2.2.2/3.fc11/i586/iptstate-2.2.2-3.fc11.i586.rpm http://kojipkgs.fedoraproject.org/packages/iptstate/2.2.2/3.fc12/i686/iptstate-2.2.2-3.fc12.i686.rpm | grep libnetfilter
libnetfilter_conntrack.so.3  
libnetfilter_conntrack.so.3  
libnetfilter_conntrack.so.1                 <-----

Comment 16 Mitchell Berger 2009-11-18 04:22:34 UTC
Oh, I see.  The original libnetfilter_conntrack update *also* happened
after the point where things built in Rawhide no longer automatically
became tagged into F12.  So, your F11 machine had
libnetfilter_conntrack-0.0.100-1.fc11, and it's trying to update to
libnetfilter_conntrack-0.0.99-3.fc12, because 0.0.100-1 doesn't
exist in the F12 repo.  In fact, if you look in Koji, you'll find that
libnetfilter_conntrack 0.0.100-1 was never even built for F12, let
alone submitted as an update.

So, the new libnetfilter_conntrack needs to be built and pushed to
F12, and then iptstate needs to be rebuilt against it in F12 and
pushed out.

Comment 17 Paul P Komkoff Jr 2009-11-18 10:40:32 UTC
I'll fix it today.
For now you can ignore iptstate update f11->f12, I guess

Comment 18 Joel 2009-11-20 21:23:08 UTC
Is this going to be rebuilt for f12 any time soon?

Nothing since the 11th!:

http://koji.fedoraproject.org/koji/packageinfo?packageID=702

Comment 19 Paul P Komkoff Jr 2009-11-21 13:17:34 UTC
Yes it will.
I am waiting for fedora releng to manually create a dist-override for me 
https://fedorahosted.org/rel-eng/ticket/3163


Note You need to log in before you can comment on or make changes to this bug.