Bug 53670 - ifdown releases DHCP lease, unlike Windows.
Summary: ifdown releases DHCP lease, unlike Windows.
Status: CLOSED DUPLICATE of bug 46942
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-14 15:02 UTC by Mark Fassler
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Fassler 2001-09-14 15:02:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010702

Description of problem:
"ifdown ifcfg-eth0" will issue this command:
pump -r -i eth0

This causes the client to release its IP address, which Windows does not do.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Do a controlled shutdown of an ethernet interface that uses pump for DHCP


Actual Results:  pump gave a DHCPRELEASE message to the dhcp server,
freeing up the IP address.

Expected Results:  Windows does not issue a DHCPRELEASE upon controlled
shutdown.  Issuing a DHCPRELEASE is not a requirement nor a suggestion in
RFC2131.

Additional info:

This isn't a bug exactly - RFC2131 allows for DHCPRELEASE on controlled
shutdown; however, it doesn't recommend it either (unless the computer is
being permanently moved to another network).

Perhaps there should be an option in
/etc/sysconfig/network-scripts/ifcfg-eth* that allows for explicit Windows
compatability with DHCP.  


(...even more info...)

This is a minor problem on our (mostly Windows) network.  The administrator
won't give out static IP addresses, but does give a DHCP lease time of 8
days.  Some of the researchers have access to computers elswhere, but the
admins of those computers will only allow access from specific IP addresses
for security reasons.  

So the researchers have, at least, an unchanging IP address as long as they
don't turn off their computer for more than 8 days.  Unfortunately,
ifdown/pump issues a DHCP release, causing them to lose their IP address
almost every time they turn off their computer.

Comment 1 Bill Nottingham 2005-01-06 22:45:54 UTC

*** This bug has been marked as a duplicate of 46942 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:48:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.