Bug 53675 - syslogd averaging 60% CPU with load average over 6%
Summary: syslogd averaging 60% CPU with load average over 6%
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: sysklogd   
(Show other bugs)
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-14 18:40 UTC by Kevin Cheramie
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 15:38:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of my top info and dmesg. (12.42 KB, text/plain)
2001-09-14 18:42 UTC, Kevin Cheramie
no flags Details

Description Kevin Cheramie 2001-09-14 18:40:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Syslogd averages between %50 and %60 CPU with load averages above 6.0 on 
my Dell PowerEdge 2500 w/ 1GHZ processor and 1Gig RAM.  POP3 mail seems to 
be very slow also, but I don't know if these are related. I have not made 
any changes to the default /etc/syslog.conf file. I am running sysklogd-
1.4.1-4.i386.rpm rawhide.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.enter 'top' at the command prompt.
2.observe.
3.Freak out because syslogd is eating so much CPU.
	

Actual Results:  I called Red Hat Tech Support and they had me install a 
new syslogd from the following rpm:
sysklogd-1.4.1-4.i386.rpm

Expected Results:  CPU usage drop to around %1 or %2.

Additional info:

see attached file.

Comment 1 Kevin Cheramie 2001-09-14 18:42:05 UTC
Created attachment 31796 [details]
screenshot of my top info and dmesg.

Comment 2 Bill Nottingham 2001-10-02 15:38:22 UTC
Among other things...

- you've run out of file descriptors and memory at least at one point, which is
not good
- how fast are your logs growing? It really could be logging that much...

Comment 3 Bill Nottingham 2002-01-25 04:27:36 UTC
closed, lack of response.


Note You need to log in before you can comment on or make changes to this bug.