Bug 53679 - mkinitrd 3.2.6-1 not backwards compatible with 2.2.19-7.0.8 kernel
mkinitrd 3.2.6-1 not backwards compatible with 2.2.19-7.0.8 kernel
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-09-14 17:17 EDT by Pete Zaitcev
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-22 10:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Matthews 2001-09-14 17:17:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
It appears as if mkinitrd-3.2.6-1 won't build a usable initrd for the
2.2.19-7.0.8 kernel.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
- Upgrade mkinitrd to 3.2.6-1
- Install 2.2.19-7.0.8 kernel rpm.  Build initrd.
- Reboot into 2.2.19.  Boot fails at pivot_root:
  pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 38
- Downgrade to mkinitrd-2.6-1 and retry.
- Everything's hunky-dory.

Additional info:

Here is some additional puzzling info.  Mkinitrd-3.2.6-1 works fine for me
with 2.2.16-22 and all the 2.4.x kernels I tried.  So, it is just the
2.2.19 based errata kernel that flunks.

I don't think this is a major problem.  The only people who will get caught
are those who do a clean install of 7.2 and then want to install the 7.0
errata kernel.
Comment 1 Pekka Savola 2002-02-25 11:25:59 EST
We got hit by this too.

IMO, it is important to be able to provide backward-compatibility via a switch
or something,
because there will be valid reasons for installing 2.2. w/ initrd on RHL7[12]
systems; IMO, this
is much better than having to install RHL7 if you want to play with 2.2.

So raising severity.
Comment 2 Erik Troan 2002-05-21 18:56:44 EDT
do you know what's broken? is it ext3 stuff?
Comment 3 Pekka Savola 2002-05-22 01:48:32 EDT
The problem IMO is that mkinitrd only supports 2.4.x pivot-root mechanism,
the old one used for 2.2 is no longer supported.

Pivot-root isn't implemented for 2.2...

(I think bmatthews made some accident there, I would be very suprised if new
mkinitrd works with 2.2.16-22)
Comment 4 Erik Troan 2002-05-22 09:07:17 EDT
I just added --nopivot to mkinitrd, which skips the pivot stuff. This should
result in initrd's that work just like the ones from old versions.

*Please* test this change; I don't have any machines I can test this on very
easily. You can get the sources from:


report back here if it works.
Comment 5 Pekka Savola 2002-05-22 10:24:02 EDT
I tested this by installing latest errata kernel from 7.0 on a 7.2 system.  The
system had root-raid so
initrd was necessary.

With --nopivot, it worked nicely, thanks!

Two additional notes:
 1) new mkinitrd conflicts with older kernels' /sbin/install-kernel; no problem.
 2) mkinitrd must BuildPreReq dietlibc :-)
Comment 6 Erik Troan 2002-05-22 12:38:13 EDT
Glad it works...

#2 can't be done as RPM doesn't support platform dependent build requires.

Note You need to log in before you can comment on or make changes to this bug.