Bug 536828 - initscript collected problems LSB-compilant ebtables
initscript collected problems LSB-compilant ebtables
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ebtables (Show other bugs)
6.1
All Linux
high Severity medium
: rc
: ---
Assigned To: Thomas Woerner
qe-baseos-daemons
:
Depends On:
Blocks: 633349
  Show dependency treegraph
 
Reported: 2009-11-11 09:45 EST by Jan Ščotka
Modified: 2010-09-13 12:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: ebtables-2.0.9-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2009-11-11 09:45:02 EST
I found 2 problems, with LSB compilant of initscript of arpwatch.
It should be based on 
https://fedoraproject.org/wiki/Packaging/SysVInitScript definition
test srcipt is situated on wiki pages:
https://wiki.test.redhat.com/BaseOs/Projects/InitScripts#testscript


::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test                                                         
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: >>>>>>>>> service start
:: [   PASS   ] ::  Service must start without problem
:: [   PASS   ] ::  Then Status command               
:: [   PASS   ] ::  Already started service           
:: [   PASS   ] ::  Again status command              
:: [   LOG    ] :: >>>>>>>>> service restart          
:: [   PASS   ] ::  Restarting of service             
:: [   PASS   ] ::  Status command                    
:: [   LOG    ] :: >>>>>>>>> service stop             
:: [   PASS   ] ::  Stopping service                  
:: [   FAIL   ] ::  Status of stopped service  (Expected 3, got 0)
:: [   PASS   ] ::  Stopping service again                        
:: [   FAIL   ] ::  Status of stopped service  (Expected 3, got 0)
:: [   LOG    ] :: >>>>>>>>> pid file                             
:: [   FAIL   ] :: File /var/run/ebtables.pid should exist        
:: [   PASS   ] :: Running 'echo 666666 > /var/run/ebtables.pid'  
:: [   FAIL   ] ::  Existing pid file, but service not started  (Expected 1, got 0)
:: [   LOG    ] :: >>>>>>>>> lock file                                             
:: [   FAIL   ] :: File /var/lock/subsys/ebtables should exist                     
:: [   PASS   ] :: Running 'touch /var/lock/subsys/ebtables'                       
:: [   FAIL   ] ::  Existing lock file, but service not started  (Expected 2, got 0)
:: [   LOG    ] :: >>>>>>>>> insufficient rights                                    
:: [   PASS   ] ::  Starting service for restarting under nonpriv user              
:: [   FAIL   ] :: Insufficient rights, restarting resrvice under nonprivileged user must fail (Expected 4, got 0)                                                                                  
:: [   LOG    ] :: >>>>>>>>> operations
:: [   PASS   ] ::  Service have to implement start function
:: [   PASS   ] ::  Service have to implement restart function
:: [   PASS   ] ::  Service have to implement status function
:: [   FAIL   ] ::  Service have to implement usage function  (Expected 0,3,2, got 1)
:: [   FAIL   ] ::  Service have to implement condrestart function  (Expected 0,3, got 1)
:: [   FAIL   ] ::  Service have to implement try-restart function  (Expected 0,3, got 1)
:: [   PASS   ] ::  Service have to implement reload function
:: [   FAIL   ] ::  Service have to implement force-reload function  (Expected 0,3, got 1)
:: [   LOG    ] :: >>>>>>>>> nonexist operations
:: [   FAIL   ] ::  Testing proper return code when nonexisting function (Expected 2, got 1)
:: [   LOG    ] :: >>>>>>>>> invalid arguments
:: [   FAIL   ] ::  When no arguments added to service, it must fail with proper return code  (Expected 2, got 1)
:: [   LOG    ] :: Duration: 41s
:: [   LOG    ] :: Assertions: 15 good, 13 bad


there is lots of failing issues, please fix all FAILing tests (I hope that descriptions are selfexplanatory)
Comment 2 RHEL Product and Program Management 2009-11-11 10:15:48 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Thomas Woerner 2010-01-15 07:45:10 EST
These are the remaining problems that are not fixable, because there is no running daemon, therefore there is no pid file and /var/lock/subsys/ebtables is used to test if the service is started or not.

:: [   LOG    ] :: >>>>>>>>> pid file
:: [   FAIL   ] :: File /var/run/ebtables.pid should exist 
:: [   PASS   ] :: Running 'echo 666666 > /var/run/ebtables.pid'
:: [   FAIL   ] ::  Existing pid file, but service not started  (Expected 1, got 3)
:: [   LOG    ] :: >>>>>>>>> lock file
:: [   PASS   ] :: File /var/lock/subsys/ebtables should exist
:: [   PASS   ] :: Running 'touch /var/lock/subsys/ebtables'
:: [   FAIL   ] ::  Existing lock file, but service not started  (Expected 2, got 0)

Fixed in ebtables-2.0.9-3.el6.

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2202003
Comment 7 Jan Ščotka 2010-03-12 05:07:10 EST
Hi,
components seems to have repaired most of bugs.
see RHTS run:
http://rhts.redhat.com/cgi-bin/rhts/test_log.cgi?id=12819126

there are still problems with pid file and lock file, bud as developer said, is is not normal service, so it is acceptable.

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: TEST PROTOCOL
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: Test run ID   : 2924442
:: [   LOG    ] :: Package       : ebtables
:: [   LOG    ] :: Installed:    : ebtables-2.0.9-3.el6.i686
:: [   LOG    ] :: Test started  : 2010-03-12 04:50:04
:: [   LOG    ] :: Test finished : 2010-03-12 04:50:12
:: [   LOG    ] :: Test name     : /CoreOS/ebtables/Sanity/initscipts
:: [   LOG    ] :: Distro:       : Red Hat Enterprise Linux release 6.0 Beta (Santiago)
:: [   LOG    ] :: Hostname      : hp-dl160g6-01.rhts.bos.redhat.com
:: [   LOG    ] :: Architecture  : i686

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test description
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

Hi
there was founded several problems with LSB-compilant of initscript of arpwatch.
It should be based on 
https://fedoraproject.org/wiki/Packaging/SysVInitScript definition
test srcipt is situated on wiki pages:
https://wiki.test.redhat.com/BaseOs/Projects/InitScripts#testscript

see failing message in LOG bellow:


::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: >>>>>>>>> service start
:: [   PASS   ] ::  Service must start without problem
:: [   PASS   ] ::  Then Status command 
:: [   PASS   ] ::  Already started service 
:: [   PASS   ] ::  Again status command 
:: [   LOG    ] :: >>>>>>>>> service restart
:: [   PASS   ] ::  Restarting of service
:: [   PASS   ] ::  Status command 
:: [   LOG    ] :: >>>>>>>>> service stop
:: [   PASS   ] ::  Stopping service 
:: [   PASS   ] ::  Status of stopped service 
:: [   PASS   ] ::  Stopping service again 
:: [   PASS   ] ::  Status of stopped service 
:: [   LOG    ] :: >>>>>>>>> pid file
:: [   FAIL   ] :: File /var/run/ebtables.pid should exist 
:: [   PASS   ] :: Running 'echo 666666 > /var/run/ebtables.pid'
:: [   FAIL   ] ::  Existing pid file, but service not started  (Expected 1, got 3)
:: [   LOG    ] :: >>>>>>>>> lock file
:: [   PASS   ] :: File /var/lock/subsys/ebtables should exist
:: [   PASS   ] :: Running 'touch /var/lock/subsys/ebtables'
:: [   FAIL   ] ::  Existing lock file, but service not started  (Expected 2, got 0)
:: [   LOG    ] :: >>>>>>>>> insufficient rights
:: [   PASS   ] ::  Starting service for restarting under nonpriv user 
:: [   PASS   ] :: Insufficient rights, restarting resrvice under nonprivileged user must fail
:: [   LOG    ] :: >>>>>>>>> operations
:: [   PASS   ] ::  Service have to implement start function 
:: [   PASS   ] ::  Service have to implement restart function 
:: [   PASS   ] ::  Service have to implement status function 
:: [   PASS   ] ::  Service have to implement usage function 
:: [   PASS   ] ::  Service have to implement condrestart function 
:: [   PASS   ] ::  Service have to implement try-restart function 
:: [   PASS   ] ::  Service have to implement reload function 
:: [   PASS   ] ::  Service have to implement force-reload function 
:: [   LOG    ] :: >>>>>>>>> nonexist operations
:: [   PASS   ] ::  Testing proper return code when nonexisting function
:: [   LOG    ] :: >>>>>>>>> invalid arguments
:: [   PASS   ] ::  When no arguments added to service, it must fail with proper return code 
:: [   LOG    ] :: Duration: 8s
:: [   LOG    ] :: Assertions: 25 good, 3 bad
:: [   FAIL   ] :: RESULT: Test
Comment 9 releng-rhel@redhat.com 2010-07-02 15:02:16 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.