Bug 536830 - initscript collected problems LSB-compilant gpsd
initscript collected problems LSB-compilant gpsd
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Dennis Gregorovic
Release Test Team
:
Depends On:
Blocks: 633349
  Show dependency treegraph
 
Reported: 2009-11-11 09:48 EST by Jan Ščotka
Modified: 2010-09-13 12:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: gpsd-2.39-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-10 16:00:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Ščotka 2009-11-11 09:48:46 EST
I found 2 problems, with LSB compilant of initscript of arpwatch.
It should be based on 
https://fedoraproject.org/wiki/Packaging/SysVInitScript definition
test srcipt is situated on wiki pages:
https://wiki.test.redhat.com/BaseOs/Projects/InitScripts#testscript

see failing message in LOG:
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test                                                         
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: >>>>>>>>> service start
:: [   PASS   ] ::  Service must start without problem
:: [   PASS   ] ::  Then Status command               
:: [   PASS   ] ::  Already started service           
:: [   PASS   ] ::  Again status command              
:: [   LOG    ] :: >>>>>>>>> service restart          
:: [   PASS   ] ::  Restarting of service             
:: [   PASS   ] ::  Status command                    
:: [   LOG    ] :: >>>>>>>>> service stop             
:: [   PASS   ] ::  Stopping service                  
:: [   PASS   ] ::  Status of stopped service         
:: [   PASS   ] ::  Stopping service again            
:: [   PASS   ] ::  Status of stopped service         
:: [   LOG    ] :: >>>>>>>>> pid file                 
:: [   PASS   ] :: File /var/run/gpsd.pid should exist
:: [   PASS   ] :: Running 'echo 666666 > /var/run/gpsd.pid'
:: [   PASS   ] ::  Existing pid file, but service not started 
:: [   LOG    ] :: >>>>>>>>> lock file                         
:: [   PASS   ] :: File /var/lock/subsys/gpsd should exist     
:: [   PASS   ] :: Running 'touch /var/lock/subsys/gpsd'       
:: [   PASS   ] ::  Existing lock file, but service not started 
:: [   LOG    ] :: >>>>>>>>> insufficient rights                
:: [   PASS   ] ::  Starting service for restarting under nonpriv user 
:: [   FAIL   ] :: Insufficient rights, restarting resrvice under nonprivileged user must fail (Expected 4, got 0)
:: [   LOG    ] :: >>>>>>>>> operations
:: [   PASS   ] ::  Service have to implement start function
:: [   PASS   ] ::  Service have to implement restart function
:: [   PASS   ] ::  Service have to implement status function
:: [   PASS   ] ::  Service have to implement usage function
:: [   PASS   ] ::  Service have to implement condrestart function
:: [   PASS   ] ::  Service have to implement try-restart function
:: [   PASS   ] ::  Service have to implement reload function
:: [   PASS   ] ::  Service have to implement force-reload function
:: [   LOG    ] :: >>>>>>>>> nonexist operations
:: [   PASS   ] ::  Testing proper return code when nonexisting function
:: [   LOG    ] :: >>>>>>>>> invalid arguments
:: [   PASS   ] ::  When no arguments added to service, it must fail with proper return code
:: [   LOG    ] :: Duration: 47s
:: [   LOG    ] :: Assertions: 27 good, 1 bad
:: [   FAIL   ] :: RESULT: Test

So, there is only one issue, what should be fixed ( when working under nonprivileged user it should return code 4
Comment 2 RHEL Product and Program Management 2009-11-11 10:15:52 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Miroslav Lichvar 2010-01-22 07:06:34 EST
Should be fixed in gpsd-2.39-6.el6.
Comment 8 Dennis Gregorovic 2010-03-10 16:00:40 EST
Closing since gpsd isn't slated for RHEL 6

Note You need to log in before you can comment on or make changes to this bug.