Bug 536878 - abrt shouldn't be in the menus
Summary: abrt shouldn't be in the menus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 12
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 533484 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-11 16:57 UTC by Jonathan Blandford
Modified: 2015-02-01 22:49 UTC (History)
11 users (show)

Fixed In Version: 1.0.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-01 04:38:17 UTC


Attachments (Terms of Use)

Description Jonathan Blandford 2009-11-11 16:57:42 UTC
abrt-gui seems to install a .desktop file that appears in the system menus.  We should make it NoDisplay=True, as it seems to provide no value whatsoever:

* There are no translations in the .desktop file.  It always appears in English
* Running it doesn't seem to do anything, either from the command line or the menu
* It's an "Automatic Bug Reporting Tool."  Why would I run it????

Comment 1 Michal Nowak 2009-11-12 10:05:33 UTC
(In reply to comment #0)
> * There are no translations in the .desktop file.  It always appears in English

That can be fixed for sure.

> * Running it doesn't seem to do anything, either from the command line or the
> menu

Can you be more specific? What does it mean 'anything'? abrt-gui should pop up with list of your crashes, if any.

> * It's an "Automatic Bug Reporting Tool."  Why would I run it????  

That's just a name. It's more manual at this time, but the plan is to have auto-reporting functionality, for kerneloops at least, also.

What version, please?

Comment 2 Jiri Moskovcak 2009-11-15 12:37:13 UTC
I made the desktop file translatable, so it should appear localized once someone translate it. And can you please answer the question from comment #1?

Thanks,
Jirka

Comment 3 Jiri Moskovcak 2009-11-22 19:31:53 UTC
*** Bug 533484 has been marked as a duplicate of this bug. ***

Comment 4 Ville-Pekka Vainio 2009-11-22 19:53:45 UTC
(In reply to comment #2)
> I made the desktop file translatable

Thanks!

Comment 5 Fedora Update System 2009-11-22 20:44:37 UTC
abrt-1.0.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/abrt-1.0.0-1.fc12

Comment 6 Fedora Update System 2009-11-25 15:10:38 UTC
abrt-1.0.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update abrt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12098

Comment 7 Fedora Update System 2009-12-01 04:37:21 UTC
abrt-1.0.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.