Bug 53698 - GeForce 2 Go incorrectly configured on Dell Inspiron 8000
GeForce 2 Go incorrectly configured on Dell Inspiron 8000
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-15 12:45 EDT by Chris Chabot
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-15 12:47:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rosswell generated config file (non working) (2.60 KB, text/plain)
2001-09-15 12:46 EDT, Chris Chabot
no flags Details
Modified config file (working) (2.05 KB, text/plain)
2001-09-15 12:47 EDT, Chris Chabot
no flags Details

  None (edit)
Description Chris Chabot 2001-09-15 12:45:53 EDT
Using the Rosswell beta2 installed the GeForce2 Go Card was detected
(properly, mad props for this).

However the mode lines generated for this card are disfunctional. Also the
horiz-syn and vert-sync are not detected and default to a range that
invalidates the generated mode lines.

I got the thing to work by replaceing the mode lines (got them from the
dell site, hsync 31.5-90, vsync 60), and commenting out the generated mode
lines.

Then i added Option "IgnoreEDID" "1" to the config file, and all worked fine.

My laptop is a :
Dell Inspiron 8000, P3 900Mhz, 512Mb ram, 20Gb disk, 15" 1450x1050 screen,
with a GeForce2 Go, 32 Mb card (memory properly detected, also 1400x1050 is
properly shown as resolution option!)

I tested this with the provided XFree driver, and NVIDIA's drivers, the
results are the same on both.
Comment 1 Chris Chabot 2001-09-15 12:46:42 EDT
Created attachment 31817 [details]
Rosswell generated config file (non working)
Comment 2 Chris Chabot 2001-09-15 12:47:06 EDT
Created attachment 31818 [details]
Modified config file (working)
Comment 3 Mike A. Harris 2001-09-18 04:24:14 EDT
GeForce 2 Go is not supported by this release of XFree86.

http://www.xfree86.org/4.1.0/Status22.html#22
Comment 4 Chris Chabot 2001-09-18 08:41:03 EDT
Damn you guys can be so 'high and mighty'. If you actualy read the link you gave
it reads (at the bottom)

"Support for the newer chips (GeForce2 and later) is only available in 4.1.0"

And roswell happens to run 4.1.0 (rpm -qa and x output tells me that without a
doubt).

Further, you show the GeForce2 Go in the installer !! You even correctly handle
memory detection and mode line generation (or attempt to).

Sorry but i put a bit of effort into this stuff as well trying to help you guys
out in a opensource spirit kind of way.. and this kinda stuff is NOT motivating
@ all to keep helping out

Now you tell your clients it supports a geforce2 go during install, then it
doesnt work, and they come here to find its 'not supported'. ?? 
Thats confusing, and a bad way to deal with people using your product. Either
choose not to support it (though it does/can work and 4.1.0 supports it). Or fix
the bugs so people can install redhat 7.2 on there laptops without any problems...
Comment 5 Mike A. Harris 2001-09-18 10:19:24 EDT
There is absolutely *NOTHING* "high and mighty" about it.  The Geforce 2 Go
card is not supported out of the box by the XFree86 4.1.0 nv driver.

Wherever possible, I try to obtain stable patches that add support to
our releases for hardware not immediately supported by the stock XFree86
code.  It is *NOT* possible to add support to the driver to support new
nvidia hardware without working for Nvidia, since Nvidia does not release
the technical specifications to its hardware.

Now *think* about this -> "Geforce 2 and later".  Do you really think that
that is possible?  It is saying "Geforce 2 and all cards that have come
out since then" if you reword it.  One would imply from that that it supports
the "Geforce 7 UltraMega Go Deluxe Turbo Edition", since that is "later"
than Geforce 2.  However, 4.1.0 does *NOT* support the
"Geforce 7 UltraMega Go Deluxe Turbo Edition", and it does *NOT* support
the Geforce 2 Go either.  I thought I made that clear and concise, and was
not in any way rude or high and mighty.

Looking in the xf86PciInfo.h file we find the define for the geforce 2 go
as: #define PCI_CHIP_GEFORCE2GO     0x0112
That indicates that someone has added the PCI ID to the known PCI ID's in
XFree86, and does not in any way shape or form imply that the driver has
been updated or enhanced to support the hardware at all.

Now we move into the actual driver source code:

A grep of the entire source results in a single line being found for this
PCI ID:

nv_type.h:#define NV_CHIP_GEFORCE2GO      ((PCI_VENDOR_NVIDIA  << 16) |
PCI_CHIP_GEFORCE2GO)
What does this mean?  It means that the driver aparently has had work
started on it to support the card.  A card is considered "supported"
*BY RED HAT* when a driver is complete enough to be considered fairly
useable and stable, and has been tested to some degree with actual
hardware, and ONLY for cards explicitly listed in the status document.

This card is NOT listed in that document, and is thus UNSUPPORTED.

We have added the PCI ID's to our pci table so that the card *can*
be detected and is known instead of showing up as "unknown".  In the
case that the card *does* get supported in a future X patch or release
and is released as an erratum, it is nice to have our tools be aware
of the card in advance, so that users like you don't have to upgrade
900 other tools also when upgrading X to get support for a previously
unsupported card.

Sorry, but your rude and obnoxious remarks which are IMHO totally
unwarranted do NOT make me motivated to prioritize adding support
for this to the top of my list.  As an open source developer I choose
to collaborate with the community via the XFree86 mailing lists, IRC,
Red Hat mailing lists, and direct contact with developers to ensure
our releases of XFree86 are as stable as possible, and give our
users the best release possible.  I focus my efforts and energy where
it gives the most benefit, and the most pleasureable experience. This
is not one of those pleasureable experiences.

The XFree86 mailing list archives *clearly* show that this card is
not supported also.  You can look for David Woodhouse's thread on
the Geforce 2 Go.  The solution to the problem for him, was to have
it replaced with ATI hardware supported fully by open source drivers.
You too might want to consider that solution.

Summary: GeForce 2 Go is not supported by this release of XFree86.




Comment 6 David Woodhouse 2001-09-18 10:42:42 EDT
The config file above seems to be using the 'nvidia' binary-only driver, and as
such is unfortunately not appropriate for shipping with Red Hat Linux. Users
installing this driver are no longer eligible for any support from Red Hat, and
indeed unlikely to receive any assistance from anyone but nVidia themselves. It
would be unwise for Red Hat to make it easy for users to enter that unfortunate
situation.

It is my experience that the XFree86 'nv' driver which is in 4.1.0 and shipped
with the Roswell beta release cannot display to the LCD on the I8000, only to
the external display.

The Dell part number for a suitable replacement is apparently:
5E444 -  ASSY,PWA,GRPH,8M,ATI,PONG,INSP ATI Video Card, 8MB

I found a 16MiB version, which cost me only 40 GBP. The replacement procedure is
fairly simple and well-documented at 
http://docs.us.dell.com/docs/systems/plav/remove.htm#1051438

Comment 7 Mike A. Harris 2001-10-20 18:40:24 EDT
Just to clarify this issue even more, right from the horses mouth:



Date: Sat, 20 Oct 2001 14:39:19 -0700 (PDT)
From: Mark Vojkovich <mvojkovich@nvidia.com>
To: XFree86 devel list <devel@xfree86.org>
Content-Type: TEXT/PLAIN; charset=US-ASCII
Subject: Re: Nvidia status document:
 
On Sat, 20 Oct 2001, Thomas Witzel wrote:
 
> What means GeForce2 Go is not supported ? XFree runs on mine...
>
 
   Some people have said the Toshiba laptops work with the "nv" driver.
I've never seen it work, and frankly, I don't see how it can.  It
certainly doesn't work on the one we have here.  Must be some sort
of bios miracle you are seeing.  The "nv" driver definitely does not
support the GeForce2 Go in terms of having code required to make
it work for the general case.
 
                                Mark.

Note You need to log in before you can comment on or make changes to this bug.