Bug 537008 - xorg-server 1.7.1 & KDE: slow graphics
Summary: xorg-server 1.7.1 & KDE: slow graphics
Keywords:
Status: CLOSED DUPLICATE of bug 533620
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-12 07:31 UTC by Jost Diederichs
Modified: 2009-11-12 15:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-12 15:55:32 UTC


Attachments (Terms of Use)

Description Jost Diederichs 2009-11-12 07:31:50 UTC
Description of problem:
Slow response (1 to 3 sec lag) of KDE Plasma components, most notably Kickoff.

Version-Release number of selected component (if applicable):
1.7.1-7

How reproducible:
every time

Steps to Reproduce:
Launch an application from KDE kicker and wait.


Additional info:
This problem has been looked at in some detail here:
http://bugs.archlinux.org/task/17037#comment52785

The problem can be isolated to the following patch:
xserver-1.7.1-window-pictures.patch

If I modify the patch as suggested in the above link, namely only apply the first section of the patch:
-    pPixmap = (*pScreen->CreatePixmap) (pScreen, width, height, pDraw->depth, 0);
+    pPixmap = fbCreatePixmap (pScreen, width, height, pDraw->depth, 0);

 , everything works fine, including the picture window problem this patch addresses.

Comment 1 Rex Dieter 2009-11-12 15:55:32 UTC

*** This bug has been marked as a duplicate of bug 533620 ***


Note You need to log in before you can comment on or make changes to this bug.