Bug 53704 - Changing IP address, ifdown/ifup causes old IP and route to show up
Changing IP address, ifdown/ifup causes old IP and route to show up
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: net-tools (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-15 20:36 EDT by David Morse
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-15 20:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Morse 2001-09-15 20:36:46 EDT
Description of problem:
When I change an interface address i.e. from 192.1.1.32 to 192.1.3.32, 
either via netconfig -d ethN or manually editing /etc/sysconfig/network-
scripts/ifcfg-ethN, ifdown ethN and ifup ethN, and do a route, I still see 
the old IP and two routing entries (one for the old IP, one for the new).

Version-Release number of selected component (if applicable): 1.6.0-3


How reproducible:
Always

Steps to Reproduce:
1. use netconfig -d eth0 to assign eth0 IP 192.1.1.32, bring interface up.
2. type route, 192.1.1.0 route exists as expected
2. use netconfig -d eth0 to assign eth0 IP 192.1.2.32, bring interface 
down (gets error) and up
3. type ifconfig, old IP (192.1.1.32) still shows up; 192.1.2.32 should 
show up
4. type route, 192.1.2.0 AND 192.1.1.0 exists (only 192.1.2.0 should 
exist).


Actual Results:  When bringing interface down after IP change in step 2, I 
get "RTNETLINK answers: Cannot assign requested address." and it doesn't 
appear to remove the 192.1.1.0 route, because running route after bringing 
the interface up after the IP change shows both networks:

Destination   Gateway   Genmask        Flags Metric Ref   Use Iface
192.1.1.0     *         255.255.255.0  U     0      0       0 eth0
192.1.2.0     *         255.255.255.0  U     0      0       0 eth0
127.0.0.0     *         255.255.255.0  U     0      0       0 lo

ifconfig shows old IP address for eth0 (192.1.1.32).

Expected Results:  ifconfig should show 192.1.2.32 IP after all the above 
steps.

It should have correctly removed the 192.1.1.0 route on ifdown, and 
brought ONLY 192.1.2.0 route up and assigned 192.1.2.32 IP.

Additional info:

It seems that the problem lies in the ifdown; if you change the IP 
in /etc/sysconfig/network-scripts/ifcfg-ethN while the interface is still 
up, it gives an error when you try to ifdown it.  Therefore when you try 
to ifup with the new IP, it still has the old IP and route (along with the 
new route which is useless).
Comment 1 Bill Nottingham 2001-09-26 16:44:23 EDT
This should be fixed in initscripts-6.40.1-1.

Note You need to log in before you can comment on or make changes to this bug.