Bug 537071 - samba: add share resource fail if added with maximum length characters input for 'Resource Name' and 'Name' fields from iManage UI
samba: add share resource fail if added with maximum length characters input ...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.4
x86_64 Linux
low Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
: SubBug
Depends On:
Blocks: RHQ_Config rhq_triage
  Show dependency treegraph
 
Reported: 2009-11-12 06:51 EST by Rajan Timaniya
Modified: 2014-05-16 09:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-16 09:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot for exception (137.64 KB, image/png)
2009-11-12 06:51 EST, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2009-11-12 06:51:09 EST
Created attachment 369197 [details]
screenshot for exception

Description of problem:
samba: add share resource fail if added with maximum length characters input for 'Resource Name' and 'Name' fields from iManage UI
Test case: https://engineering.redhat.com/trac/IntegratedMgmtQE/wiki/Spearhead_RHEL_config_samba_Testplan
(User_story_278:Testcase -24)

Version-Release number of selected component (if applicable):
version: 1.4.0-SNAPSHOT

How reproducible:


Steps to Reproduce:
1. Connect to iManage (http://dhcp6-150.pnq.redhat.com:7080/Login.do) 
2. Log in into iManage using appropriate credential (rhqadmin/rhqadmin) 
3. Click on 'Overview -> Dashboard' 
4. Click on 'Samba Server' under 'Recently Added Resources' section 
5. Click on 'inventory' 
6. Select 'Create New: -Samba Share' then click on 'OK' 
7. Input following property values 
	Resource Name: rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr....
	Name * : 
rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr....
8. Click on 'SUBMIT' 

  
Actual results:
add resource fail with following exception
Failed to send create resource request to agent. Cause: javax.ejb.EJBException:java.lang.RuntimeException: javax.transaction.RollbackException: [com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] [com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] Can't commit because the transaction is in aborted state -> java.lang.RuntimeException:javax.transaction.RollbackException: [com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] [com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] Can't commit because the transaction is in aborted state -> javax.transaction.RollbackException:[com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] [com.arjuna.ats.internal.jta.transaction.arjunacore.commitwhenaborted] Can't commit because the transaction is in aborted state -> javax.persistence.PersistenceException:org.hibernate.exception.DataException: Could not execute JDBC batch update -> org.hibernate.exception.DataException:Could not execute JDBC batch update -> java.sql.BatchUpdateException:Batch entry 0 insert into RHQ_CREATE_RES_HIST (ERROR_MESSAGE, SUBJECT_NAME, CTIME, MTIME, PARENT_RESOURCE_ID, CREATED_RESOURCE_NAME, NEW_RESOURCE_KEY, STATUS, RESOURCE_TYPE_ID, CONFIGURATION_ID, INSTALLED_PACKAGE_ID, id) values (NULL, 'rhqadmin', '1258102823159', '1258102823159', '10005', 'a123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890', NULL, 'IN_PROGRESS', '10092', '11589', NULL, '10053') was aborted. Call getNextException to see the cause.[SQLException=Batch entry 0 insert into RHQ_CREATE_RES_HIST (ERROR_MESSAGE, SUBJECT_NAME, CTIME, MTIME, PARENT_RESOURCE_ID, CREATED_RESOURCE_NAME, NEW_RESOURCE_KEY, STATUS, RESOURCE_TYPE_ID, CONFIGURATION_ID, INSTALLED_PACKAGE_ID, id) values (NULL, 'rhqadmin', '1258102823159', '1258102823159', '10005', 'a123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890', NULL, 'IN_PROGRESS', '10092', '11589', NULL, '10053') was aborted. Call getNextException to see the cause. -> ERROR: value too long for type character varying(500)(error-code=0,sql-state=22001)]

Expected results:
There should give proper user error/alert message for maximum length.

Additional info:
It doesn't show under fail entry of history section.
Comment 1 wes hayutin 2010-02-16 11:54:18 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 2 wes hayutin 2010-02-16 11:59:42 EST
making sure we're not missing any bugs in rhq_triage
Comment 3 Corey Welton 2010-10-05 09:08:14 EDT
Lowering severity/priority - not an enterprise plugin

Note You need to log in before you can comment on or make changes to this bug.