Bug 537078 - RFE: KDE integration for Firefox
RFE: KDE integration for Firefox
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Triaged
: 544851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-12 07:11 EST by Lukáš Tinkl
Modified: 2015-07-13 13:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-06 17:53:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 528510 None None None Never

  None (edit)
Description Lukáš Tinkl 2009-11-12 07:11:23 EST
OpenSUSE has introduced in its latest version some KDE integration which would be nice to also have in Fedora. 

List of the features: http://en.opensuse.org/KDE/FirefoxIntegration
Blog post describing the work done: http://www.kdedevelopers.org/node/4099
Source code: http://gitorious.org/firefox-kde-opensuse
Comment 1 Lukáš Tinkl 2009-11-12 07:24:56 EST
Detailed list of features:
- KDE file dialogs are used instead of Gnome/GTK ones
- KDE dialog for choosing "Open with..." application
- MIME types; KDE file associations are read and being used
- protocol handlers (mailto, irc, ...)
- Proxy settings from KDE are read and used
- widget and icon styles (partially)
- plasma notifications
- Preferences dialogs have apply/cancel buttons just like other KDE dialogs 
- RSS: support for adding feeds to Akregator
- support for Firefox asking and setting itself as the default KDE browser
Comment 2 Martin Stransky 2009-11-16 06:48:08 EST
Upstream bug - https://bugzilla.mozilla.org/show_bug.cgi?id=528510
Comment 3 Matěj Cepl 2009-12-07 04:50:47 EST
*** Bug 544851 has been marked as a duplicate of this bug. ***
Comment 4 Christopher Aillon 2011-01-06 17:53:33 EST
We can consider this if it gets accepted upstream.  In the meantime, closing this.

Note You need to log in before you can comment on or make changes to this bug.