Bug 537221 - virt-manager: URL install should prompt to change scratchdir perms
virt-manager: URL install should prompt to change scratchdir perms
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
All Linux
high Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-11-12 16:01 EST by Michael Monreal
Modified: 2009-12-22 10:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 10:45:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of configuration (99.21 KB, image/png)
2009-11-12 16:01 EST, Michael Monreal
no flags Details
Kickstart (1.33 KB, text/plain)
2009-11-12 16:27 EST, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-11-12 16:01:04 EST
Created attachment 369321 [details]
Screenshot of configuration

I am unable to create a new VM using a kickstart file and the following virt* stack:

libvirt-python-0.7.1-15.fc12.i686
libvirt-client-0.7.1-15.fc12.i686
libvirt-0.7.1-15.fc12.i686
virt-manager-0.8.0-7.fc12.noarch
python-virtinst-0.500.0-5.fc12.noarch

Virt-manager downloads the kernel and then shows:

---
Unable to complete install '<class 'libvirt.libvirtError'> Failure while reading monitor startup output: Connection reset by peer
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1575, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 628, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 726, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 1077, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: Failure while reading monitor startup output: Connection reset by peer
'
---
Comment 1 Michael Monreal 2009-11-12 16:26:34 EST
I ran "Finish" again to see where exactly it exits. Now, it fully downloaded vmlinuz and initrd.img but showed a different error:

---
Unable to complete install '<class 'libvirt.libvirtError'> internal error unable to start guest: char device redirected to /dev/pts/2
qemu: could not load kernel '/home/mimox/.virtinst/boot/virtinst-vmlinuz.VkCbpY': Permission denied

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/create.py", line 1575, in do_install
    dom = guest.start_install(False, meter = meter)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 628, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 726, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib/python2.6/site-packages/libvirt.py", line 1077, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error unable to start guest: char device redirected to /dev/pts/2
qemu: could not load kernel '/home/mimox/.virtinst/boot/virtinst-vmlinuz.VkCbpY': Permission denied

'
---

I don't know about the first error but this one looks like virt-manager needs ACLs again and should better tell me that? Permissions are:

11281967 3316 -rw-------. 1 mimox mimox 3387680 2009-11-12 22:19 virtinst-vmlinuz.5HdC7C
Comment 2 Michael Monreal 2009-11-12 16:27:13 EST
Created attachment 369327 [details]
Kickstart

For completeness, here is the kickstart file I used.
Comment 3 Cole Robinson 2009-11-16 14:32:07 EST
Moving to F12.

While we try to ensure that ISO media has proper permissions, we weren't prompting the user to ensure the URL download location has proper perms, and just attempting it behind the scenes.
Comment 4 Cole Robinson 2009-12-14 20:53:17 EST
Fixed upstream and in updates-testing.
Comment 5 Cole Robinson 2009-12-22 10:45:43 EST
Fixed by virt-manager-0.8.2-1, which should be in the next updates compose.

Note You need to log in before you can comment on or make changes to this bug.