This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 53726 - rpm --rebuild /path/to/XFree86-4.1.0-0.20.0.src.rpm dumps core
rpm --rebuild /path/to/XFree86-4.1.0-0.20.0.src.rpm dumps core
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-16 22:31 EDT by John Jasen
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-16 22:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Jasen 2001-09-16 22:31:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913

Description of problem:
two seperate systems, running RH Linux 7.1, get core dumps trying to
rebuild XFree86-4.1.0-0.20.0.src.rpm; from either rpm --rebuild 
XFree86-4.1.0-0.20.0.src.rpm or rpm -ba XFree86.spec.

-v+ yields no useful information.

gdb -c core yields:
[root@geisha /root]# gdb -c core
GNU gdb 5.0rh-5 Red Hat Linux 7.1
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux".
Core was generated by `/usr/lib/rpm/rpmb -ba --verbose --verbose --
/usr/src/redhat/SPECS/XFree86.spec'.
Program terminated with signal 11, Segmentation fault.
#0  0x4012bf44 in ?? ()

Please, spare me suggestions as to sig11; or pointers to the sig11 faq; or
suggestions to check my hardware; or ... One system, I could believe, as
its a frankenputer and hasn't been stable since adding the NVIDIA drivers;
but the other was a fresh install/patch and yielded a core error in the
EXACT SAME PLACE.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.acquire XFree86-4.1.0-0.20.0.src.rpm
2.rpm --rebuild XFree86-4.1.0-0.20.0.src.rpm or rpm -ivh
XFree86-4.1.0-0.20.0.src.rpm and rpm -ba XFree96.spec
3.
	

Actual Results:  [root@geisha /root]# rpm -ba -vv
/usr/src/redhat/SPECS/XFree86.spec 
Segmentation fault (core dumped)

Expected Results:  was expecting failed dependencies and a night of staring
at the spec file and/or downloading src.rpms to fulfill them; was hoping it
would compile and make rpms cleanly, so I could toast my system by installing.

Additional info:

[root@geisha /root]# uname -a
Linux geisha 2.4.9-ac10 #1 SMP Sun Sep 9 14:29:18 EDT 2001 i686 unknown
[root@geisha /root]# gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-85
[root@geisha /root]# rpm -qa | grep glibc-2glibc-2.2.2-10
Comment 1 Mike A. Harris 2001-09-18 03:26:42 EDT
It's RPM that is dumping core, not XFree86.  This is a bug in rpm, one
that has long since been fixed.  Solution is to use rpm 4.0.3.

Note You need to log in before you can comment on or make changes to this bug.