This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 537270 - RFE: Automatically shutdown guests on host shutdown
RFE: Automatically shutdown guests on host shutdown
Status: CLOSED DUPLICATE of bug 444273
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-12 19:49 EST by Henrik Nordström
Modified: 2013-01-10 00:36 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 09:08:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Henrik Nordström 2009-11-12 19:49:55 EST
Description of problem:

Currently libvirt only autostarts guests, it does not autostop guests on shutdown, causing guest corruption on host reboots.

Version-Release number of selected component (if applicable):

libvirt-0.8.1-16.fc12

How reproducible:

always

Steps to Reproduce:
1. Start a guest
2. Reboot the host
3. Start the guest again
  
Actual results:

Guest complains about unclean shutdown, checks filessytems etc. In worst case guest may even be corrupted.

Expected results:

Cleanly shut down guests before host is shutdown / rebooted.

Additional info:

A suggested init script doing this was posted on the list in July

https://www.redhat.com/archives/libvir-list/2009-July/msg00467.html

the script works for me with just a minor patch

export LC_ALL=C
instead of
LC_ALL=C


Additionally providing the option of saving & restoring the vm state instead of shutting down would be very nice, but making sure running guests are shut down is a good start.
Comment 1 Mark McLoughlin 2009-11-19 09:08:36 EST
Thanks for the report, this has been discussed several times upstream and we have a bz tracking it

*** This bug has been marked as a duplicate of bug 444273 ***

Note You need to log in before you can comment on or make changes to this bug.