Bug 53728 - g++ internal compiler error.
Summary: g++ internal compiler error.
Status: CLOSED DUPLICATE of bug 48835
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-17 09:21 UTC by Jules Colding
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 09:21:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jules Colding 2001-09-17 09:21:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010816

Description of problem:
When compiling TAO 1.1.19 I get this output:

g++ -W -Wall -Wpointer-arith -pipe -O3 -g -Wno-uninitialized
-fno-implicit-templates   -D_POSIX_THREADS -D_POSIX_THREAD_SAFE_FUNCTIONS
-D_REENTRANT -DACE_HAS_AIO_CALLS  -I/home/colding/work/src/ACE_wrappers
-DACE_HAS_EXCEPTIONS    -I/home/colding/work/src/ACE_wrappers/TAO  -c -fPIC
-o .shobj/PolicyS.o PolicyS.cpp
PolicyS.cpp: In function `void POA_CORBA_Policy::_get_policy_type_skel 
(TAO_ServerRequest &, void *, void *, Environment &)':
PolicyS.cpp:893: Internal compiler error in scan_region, at except.c:
2809
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [.shobj/PolicyS.o] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Untar ACE and TAO.
2. Compile ACE
3. Compile TAO
	

Actual Results:  The compilation will give internal compile error (2809) a
lot of places in the TAO compilation starting with the compilation of
PortableServer.

Expected Results:  The compilation should have succeeded.

Additional info:

Comment 1 Jakub Jelinek 2001-09-17 09:37:34 UTC

*** This bug has been marked as a duplicate of 48835 ***


Note You need to log in before you can comment on or make changes to this bug.