Bug 537284 - [abrt] crash detected in audacious-2.1-5.fc12 : on exit after changing the output plugin from Pulse Audio to Alsa
Summary: [abrt] crash detected in audacious-2.1-5.fc12 : on exit after changing the ou...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b51c4c8f76baeb9d2aa959c8f83...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-13 03:04 UTC by Dawid Zamirski
Modified: 2010-02-02 01:10 UTC (History)
2 users (show)

Fixed In Version: 0.4-1.fc12.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-02 01:10:14 UTC


Attachments (Terms of Use)
File: backtrace (19.39 KB, text/plain)
2009-11-13 03:04 UTC, Dawid Zamirski
no flags Details
strace (4.22 MB, text/plain)
2009-11-19 02:37 UTC, Dawid Zamirski
no flags Details

Description Dawid Zamirski 2009-11-13 03:04:42 UTC
abrt detected a crash.

Comment: Changed the output plugin from Pulse Audio to Alsa.
Attached file: backtrace
cmdline: audacious2 /home/maners/Music/Pink Floyd/Pink Floyd - A Saucerful of Secrets - Limited Edition/01 - Let There Be More Light.mpc
component: audacious
executable: /usr/bin/audacious2
kernel: 2.6.31.5-127.fc12.x86_64
package: audacious-2.1-5.fc12
rating: 3
reason: Process was terminated by signal 11

Comment 1 Dawid Zamirski 2009-11-13 03:04:44 UTC
Created attachment 369366 [details]
File: backtrace

Comment 2 Michael Schwendt 2009-11-13 11:09:00 UTC
> Comment: Changed the output plugin from Pulse Audio to Alsa.

During playback?

Btw, the ALSA output plugin in Audacious 2.1 has been discontinued/dropped in Audacious 2.2 development. Prefer the Pulse Audio output plugin.

Comment 3 Dawid Zamirski 2009-11-13 14:58:22 UTC
No, I changed the output to Alsa and then closed Audacious and after that ABRT icon notified me of the crash. I wanted to check the ALSA output because playback of MPC file was at about 4x the normal speed and wanted to see if switching the backed would help, but it didn't so I'm to use PulseAudio. 

BTW why is that closing audacious takes about 3s before is closes - I mean after you click on the 'X' it kind of freezes for a few seconds before it disappears? Should I file a BZ ticket for that or it already a known issue? The 2.1 version is very buggy overall and I'm not sure whether to report all the issues I know of as it's marked as development version anyway..

Comment 4 Michael Schwendt 2009-11-13 15:42:30 UTC
Audacious 2.1 is the current _stable_ release, see:
http://audacious-media-player.org/

Yes, it's full of bugs, but not worse than 1.5.1.  And 2.2-alpha1 was far from promising and not an option for Fedora 12.


> playback of MPC file was at about 4x the normal speed

*That* could be a real bug if it is reproducible with all mpc files. It would not be the first plugin that messes up playback in >= 1.5.1 because of doing things in an old-fashioned way (i.e. XMMS-style).


> BTW why is that closing audacious takes about 3s before is closes

When exactly? When closing it during playback? Or also when simply opening and closing it immediately? The corresponding config file would be relevant, at least.

Comment 5 Dawid Zamirski 2009-11-13 16:17:06 UTC
(In reply to comment #4)
> 
> *That* could be a real bug if it is reproducible with all mpc files. It would
> not be the first plugin that messes up playback in >= 1.5.1 because of doing
> things in an old-fashioned way (i.e. XMMS-style).
> 

Yes it happens with all MPC files.

> 
> When exactly? When closing it during playback? Or also when simply opening and
> closing it immediately? The corresponding config file would be relevant, at
> least.  

Right now I'm running a remote NX session and it seems to close immediately, regardless whether I 'play' (no sound via remote desktop -it's using a 'Dummy Output' device) or just open & close. I'll check it when I'm back at home and have the real sound card active.

Comment 6 Michael Schwendt 2009-11-13 18:30:33 UTC
A fix for the musepack plugin will be included in this update:
http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11158

[Fedora 11 and 10 are affected, too, and will get test-updates]

Comment 7 Dawid Zamirski 2009-11-14 00:11:45 UTC
Ok, I'm back @home, and the Audacious shut down delay happens only when I click the 'X' during playback. If I just open & close it's instant.

Comment 8 Dawid Zamirski 2009-11-17 02:05:29 UTC
Hi Michael,

I've just installed the audacious-plugins-2.1-16.fc12.x86_64 and it does not playback the mpc files at all. When I try to play it, the playback does not start at all and I don't get any error messages as well.

Comment 10 Dawid Zamirski 2009-11-17 15:50:32 UTC
(In reply to comment #9)
> http://kojipkgs.fedoraproject.org/packages/audacious-plugins/2.1/17.fc12/x86_64/audacious-plugins-2.1-17.fc12.x86_64.rpm
> 
> Does that build work for you?
> 
> ( http://koji.fedoraproject.org/koji/buildinfo?buildID=141606 )  

Nope, still not playback at all.

Comment 11 Michael Schwendt 2009-11-17 18:29:03 UTC
Hmm, it works flawlessly for me, but I test on i686. Another try:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=1812692

Could you please start "audacious" in an X terminal and post its output after trying to play an MPC file?

Comment 12 Dawid Zamirski 2009-11-19 02:37:54 UTC
Created attachment 370255 [details]
strace

I've installed the rpm from koji and still no change - the playback does not start at all. Running audactious from terminal does not produce any messages at all, so I have ran it with strace in hope that it provides some clues. When I pressed play or double-clicked on the mpc file in the playlist there was no indication of any activity while running with strace.

Comment 13 Michael Schwendt 2009-11-19 10:47:57 UTC
* strace is not helpful. It only shows system calls, revealing that you tried to load a different mpc file than in the original bug report.

* Running audacious in a terminal and exiting it without doing anything else, prints a few lines already:

| bluetooth: exit
| remove_bonding call
| LASTFM: (cleanup) Cleanup finished

* If the musepack plugin's "play" function had been called for starting playback, there would be additional output in the terminal. If you don't get that output with any .mpc file at all, there might be a different problem in detecting musepack files. That would be really unexpected, given that you earlier mentioned garbled/overspeeded playback.

Perhaps you disabled the musepack plugin in the preferences?

Could you please attach $HOME/.config/audacious/config and remove that config file prior to giving mpc playback another try?

Comment 14 Dawid Zamirski 2009-11-20 04:21:20 UTC
Michael,

I have just completed a clean install of F12 (formatted my /home as well) and the no playback issue is still there. The musepack plug-in is certainly enabled. 

Before doing the re-install, I have rolled back the audacious-plugins a few releases back (to -13 build) and mpc files still wouldn't play - not even the fast-playback that I've originally reported. 

The only output that I get, when running from terminal, is what you have already mentioned:

[maners@phenom ~]$ audacious2
bluetooth: exit
remove_bonding call
LASTFM: (cleanup) Cleanup finished

Comment 15 Michael Schwendt 2009-11-20 08:19:09 UTC
Going back older builds is useless, unfortunately, since they don't print much related to musepack.

If the build from comment 11 doesn't print anything "new", your musepack files are not even recognised as playable by the plugin. All this is unrelated to the original crash, btw.

Comment 16 Michael Schwendt 2009-11-20 10:48:20 UTC
Btw, are these SV7 or SV8 Musepack files?

Comment 17 Dawid Zamirski 2009-11-20 15:25:35 UTC
(In reply to comment #15)
> Going back older builds is useless, unfortunately, since they don't print much
> related to musepack.

I've rolled back to see if I can get the "speedy" playback working that I originally reported because it stopped working altogether after I ran yum update which got new audacious-plugins 

> If the build from comment 11 doesn't print anything "new", your musepack files
> are not even recognised as playable by the plugin. All this is unrelated to the
> original crash, btw.  

No, the build from comment #11 does not print anything. Of course, I'm now that the original crash report has nothing to with the MPC issues and I'n just piggybacking on this bug report :-)

(In reply to comment #16)
> Btw, are these SV7 or SV8 Musepack files?  

They're SV7. They play fine in other players: Exaile, Rhythmbox, Totem etc.

Comment 18 Michael Schwendt 2009-11-20 16:52:18 UTC
I'm starting to get angry, because this is not the only Audacious problem on x86_64. ;)

A build with a bit more debug output, preferably run with "audacious -N" and at least one attempt at playing a .mpc file:

http://koji.fedoraproject.org/koji/getfile?taskID=1819936&name=audacious-plugins-2.1-18.fc12.1.x86_64.rpm

Comment 19 Michael Schwendt 2009-11-22 18:26:30 UTC
Meanwhile, there have been multiple success reports for SV7 .mpc file playback, specifically on x86_64 and F-12, too.

Comment 20 Dawid Zamirski 2009-11-25 02:17:46 UTC
Hi Michael

Sorry it took me so long to reply but I have quite busy days lately. In the meantime, I have updated to latest audacious and audacious-plugins from updates-testing and there's no change in behaviour- no sign of life when attempting playback. Of course I tried with different MPC files (all SV7):

maners@phenom ~]$ audacious -N
** Message: Initializing Gtk+
** Message: Setting up libSAD
** Message: Loading configuration
** Message: Initializing signal handlers
** Message: Handling commandline options, part #1
** Message: Non-headless operation setup

(audacious:3154): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:3154): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:3154): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
** Message: Initializing D-Bus
** Message: Trying to initialize D-Bus
** Message: D-Bus RC
** Message: Registering remote D-Bus interfaces
** Message: D-Bus MPRIS root
** Message: D-Bus MPRIS player

** (audacious:3154): WARNING **: in mpris_player_init object->proxy == NULL, not adding some signals.
** Message: result=0x29eb340
** Message: D-Bus MPRIS tracklist
** Message: D-Bus support has been activated
** Message: Initializing plugin subsystems...
** Message: Loaded plugin (/usr/lib64/audacious/Input/aac.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/sndfile.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/tta.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/psf2.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/tonegen.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/cdaudio-ng.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/madplug.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/wavpack.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/xsf.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/adplug.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/cuesheet_ng.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/console.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/wma.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/alac.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/sid.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/musepack.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/flacng.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/timidity.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/modplug.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/vorbis.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/crossfade.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/null.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/ALSA.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/pulse_audio.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/icecast.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/filewriter.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/echo.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/sndstretch.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/crystalizer.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/voice_removal.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/ladspa.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/stereo.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/audiocompress.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/alarm.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/song_change.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/streambrowser.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/skins.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/aosd.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/evdev-plug.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/scrobbler.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/lirc.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/gtkui.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/mtp_up.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/bluetooth.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/gnomeshortcuts.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/statusicon.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/hotkey.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/vfstrace.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/rocklight.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/blur_scope.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/paranormal.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/spectrum.so)
** Message: Loaded plugin (/usr/lib64/audacious/Container/xspf.so)
** Message: Loaded plugin (/usr/lib64/audacious/Container/m3u.so)
** Message: Loaded plugin (/usr/lib64/audacious/Container/pls.so)
** Message: Loaded plugin (/usr/lib64/audacious/Transport/gio.so)
** Message: Loaded plugin (/usr/lib64/audacious/Transport/neon.so)
** Message: Loaded plugin (/usr/lib64/audacious/Transport/lastfm.so)
** Message: Loaded plugin (/usr/lib64/audacious/Transport/mms.so)
** Message: Using libshout 2.2.2

** (audacious:3154): WARNING **: Could not open file:///home/maners/.adplug/adplug.db for reading or writing: Error opening file: No such file or directory
** Message: Populating included interfaces
** Message: Handling commandline options, part #2
** Message: Setting default icon
** Message: Selecting interface skinned
** Message: Running interface skinned@0x7fc100ad9840

(audacious:3154): Gtk-CRITICAL **: gtk_menu_item_set_submenu: assertion `GTK_IS_MENU_ITEM (menu_item)' failed

(audacious:3154): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

(audacious:3154): Gtk-WARNING **: Attempting to add a widget with type GtkFixed to a container of type SkinnedWindow, but the widget is already inside a container of type SkinnedWindow, the GTK+ FAQ at http://library.gnome.org/devel/gtk-faq/stable/ explains how to reparent a widget.

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:3154): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

(audacious:3154): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:3154): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:3154): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:3154): Gtk-CRITICAL **: gtk_window_present_with_time: assertion `GTK_IS_WINDOW (window)' failed


Here's a list of audacious related packages that I have currently installed:

maners@phenom ~]$ rpm -qa | grep audacious
audacious-plugins-freeworld-alac-2.1-1.fc12.x86_64
audacious-plugins-freeworld-2.1-1.fc12.x86_64
audacious-plugins-2.1-21.fc12.x86_64
audacious-plugins-freeworld-aac-2.1-1.fc12.x86_64
audacious-plugins-wavpack-2.1-16.fc12.x86_64
audacious-2.1-7.fc12.x86_64
audacious-plugins-freeworld-tta-2.1-1.fc12.x86_64
audacious-plugins-freeworld-wma-2.1-1.fc12.x86_64
audacious-plugins-freeworld-mp3-2.1-1.fc12.x86_64
audacious-plugins-freeworld-mms-2.1-1.fc12.x86_64
audacious-libs-2.1-7.fc12.x86_64

Comment 21 Michael Schwendt 2009-11-25 12:27:03 UTC
> In the meantime, I have updated to latest audacious and
> audacious-plugins from updates-testing

Why? I've specifically made a debug build for you. See comment 18. That's the one I'd like to see the output from.

Comment 22 Dawid Zamirski 2009-11-25 15:12:23 UTC
(In reply to comment #21)
> > In the meantime, I have updated to latest audacious and
> > audacious-plugins from updates-testing
> 
> Why? I've specifically made a debug build for you. See comment 18. That's the
> one I'd like to see the output from.  

Uh sorry, I did not know that it was a special build. I have reinstalled audacious from stable repos and applied the build from comment 18, here are the results:

[maners@phenom ~]$ audacious -N
** Message: Initializing Gtk+
** Message: Setting up libSAD
** Message: Loading configuration
** Message: Initializing signal handlers
** Message: Handling commandline options, part #1
** Message: Non-headless operation setup

(audacious:14018): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:14018): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:14018): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
** Message: Initializing D-Bus
** Message: Trying to initialize D-Bus
** Message: D-Bus RC
** Message: Registering remote D-Bus interfaces
** Message: D-Bus MPRIS root
** Message: D-Bus MPRIS player

** (audacious:14018): WARNING **: in mpris_player_init object->proxy == NULL, not adding some signals.
** Message: result=0x2186540
** Message: D-Bus MPRIS tracklist
** Message: D-Bus support has been activated
** Message: Initializing plugin subsystems...
** Message: Loaded plugin (/usr/lib64/audacious/Input/sndfile.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/psf2.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/tonegen.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/cdaudio-ng.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/xsf.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/adplug.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/cuesheet_ng.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/console.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/sid.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/musepack.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/flacng.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/timidity.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/modplug.so)
** Message: Loaded plugin (/usr/lib64/audacious/Input/vorbis.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/crossfade.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/null.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/ALSA.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/pulse_audio.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/icecast.so)
** Message: Loaded plugin (/usr/lib64/audacious/Output/filewriter.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/echo.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/sndstretch.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/crystalizer.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/voice_removal.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/ladspa.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/stereo.so)
** Message: Loaded plugin (/usr/lib64/audacious/Effect/audiocompress.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/alarm.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/song_change.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/streambrowser.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/skins.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/aosd.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/evdev-plug.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/scrobbler.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/lirc.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/gtkui.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/mtp_up.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/bluetooth.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/gnomeshortcuts.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/statusicon.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/hotkey.so)
** Message: Loaded plugin (/usr/lib64/audacious/General/vfstrace.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/rocklight.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/blur_scope.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/paranormal.so)
** Message: Loaded plugin (/usr/lib64/audacious/Visualization/spectrum.so)
** Message: Loaded plugin (/usr/lib64/audacious/Container/xspf.so)
** Message: Loaded plugin (/usr/lib64/audacious/Container/m3u.so)
** Message: Loaded plugin (/usr/lib64/audacious/Container/pls.so)
** Message: Loaded plugin (/usr/lib64/audacious/Transport/gio.so)
** Message: Loaded plugin (/usr/lib64/audacious/Transport/neon.so)
** Message: Loaded plugin (/usr/lib64/audacious/Transport/lastfm.so)
** Message: Using libshout 2.2.2

** (audacious:14018): WARNING **: Could not open file:///home/maners/.adplug/adplug.db for reading or writing: Error opening file: No such file or directory
** Message: Populating included interfaces
** Message: Handling commandline options, part #2
** Message: Setting default icon
** Message: Selecting interface skinned
** Message: Running interface skinned@0x7f5d6fe80840

(audacious:14018): Gtk-CRITICAL **: gtk_menu_item_set_submenu: assertion `GTK_IS_MENU_ITEM (menu_item)' failed

(audacious:14018): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

(audacious:14018): Gtk-WARNING **: Attempting to add a widget with type GtkFixed to a container of type SkinnedWindow, but the widget is already inside a container of type SkinnedWindow, the GTK+ FAQ at http://library.gnome.org/devel/gtk-faq/stable/ explains how to reparent a widget.

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

** (audacious:14018): CRITICAL **: skin_pixmap_free: assertion `p->pixbuf != NULL' failed

(audacious:14018): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:14018): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:14018): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

(audacious:14018): Gtk-CRITICAL **: gtk_window_present_with_time: assertion `GTK_IS_WINDOW (window)' failed
mpcIsOurFD() file:///mnt/storage/Music/Metallica/Black%20Album/01%20-%20Enter%20Sandman.mpc
mpcIsOurFD() file:///mnt/storage/Music/Pink%20Floyd/Pink%20Floyd%20-%20A%20Saucerful%20of%20Secrets%20-%20Limited%20Edition/01%20-%20Let%20There%20Be%20More%20Light.mpc
mpcIsOurFD() file:///mnt/storage/Music/Slayer/Reign%20in%20Blood/01%20-%20Angel%20of%20Death.mpc
mpcIsOurFD() file:///mnt/storage/Music/The%20Doors/The%20Doors%20-%20L.A.%20Woman/05%20-%20L.a.%20Woman.mpc
mpcIsOurFD() file:///mnt/storage/Music/The%20Doors/The%20Doors%20-%20L.A.%20Woman/05%20-%20L.a.%20Woman.mpc
mpcIsOurFD() file:///mnt/storage/Music/The%20Doors/The%20Doors%20-%20L.A.%20Woman/05%20-%20L.a.%20Woman.mpc
mpcIsOurFD() file:///mnt/storage/Music/The%20Doors/The%20Doors%20-%20L.A.%20Woman/05%20-%20L.a.%20Woman.mpc

Comment 23 Michael Schwendt 2009-11-25 16:12:15 UTC
> mpcIsOurFD()
> file:///mnt/storage/Music/Metallica/Black%20Album/01%20-%20Enter%20Sandman.mpc

The plugin's simple file checker got called, but it didn't recognise the file as one it could play. Or the file was empty even. The plugin expects to find "MP+" in the first three bytes of the file. The VFS backend did not print any errors about insufficient file access permissions or read errors.

This is something completely different from the earlier playback problem and completely unrelated to my fix. The player won't use the plugin for files it did not recognise. And a bug in Audacious' VFS system would break most [if not all] other file input plugins, too.

I'm sceptical that it makes sense to continue looking at such issues. I could add even more debug output and e.g. display the file header or the file size. My test request on fedora-list and fedora-music-list has lead to success reports.
Is there anything special about /mnt/storage/ maybe? Earlier you tried files in your /home dir instead.

Comment 24 Dawid Zamirski 2009-11-25 17:00:08 UTC
Well those files play just fine in Rhythmbox, Totem or anything else. They were encoded a long time ago using Foobar, when I was still using Windows, with x-level and ReplayGain on. I have copied some files to /home but that did not make a difference. My /home/Manners/Music is a symbolic link to /mnt/storage/Music so that's why you probably saw that I play from /home.

I'm ok if you want to close this bug, as I'm not using audacious as my mail player anyway so it doesn't bother me much. I'll try to make some encodes later today from flac to mpc using the mpcenc that just went into updates-testing and see if produces playable files.

Comment 25 Michael Schwendt 2009-11-25 18:59:03 UTC
> Rhythmbox, Totem or anything else

They only play them with RPM Fusion's gstreamer-plugins-bad package though. Audacious 2.1 and older can play them _without_ any of those 3rd party audacious-plugins-freeworld packages. (in Audacious 2.2 the musepack plugin will be gone, on the other hand)


Whether this ticket stays open or not doesn't matter to me. This latest issue is unrelated to the original crash anyway. But to continue I need a test-case -- reading the source code I could spend all day patching potential problems and adding error-handling. What's missing is either a test-case that's reproducible on i686 or a reduced test-case: Evidence of what/who is the culprit. E.g. switching on/off a particular plugin maybe. Even if I add all those freeworld plugins you listed, I cannot get .mpc files to fail. I thought perhaps one of the many freeworld plugins corrupts something (e.g. the file descriptor used during the file type check), but that's not reproducible here.

Comment 26 Fedora Update System 2010-01-01 12:44:04 UTC
audacious-plugin-fc-0.4-1.fc12.2,audacious-plugins-2.2-7.fc12,audacious-2.2-4.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/audacious-plugin-fc-0.4-1.fc12.2,audacious-plugins-2.2-7.fc12,audacious-2.2-4.fc12

Comment 27 Fedora Update System 2010-01-02 03:33:05 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-7.fc12, audacious-2.2-4.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 28 Fedora Update System 2010-01-05 22:53:59 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-8.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 29 Fedora Update System 2010-01-12 23:30:31 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 30 Fedora Update System 2010-01-12 23:31:28 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 31 Fedora Update System 2010-01-12 23:32:21 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-4.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 32 Fedora Update System 2010-01-26 00:57:42 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-2.2-7.fc12, audacious-plugins-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious audacious-plugins'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 33 Michael Schwendt 2010-01-27 10:41:28 UTC
Third-party add-on packages for Audacious 2.2 are available
in their respective -updates-testing repository.

Please give feedback on the Audacious 2.2 test update:
http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

There are no plans to continue with Audacious 2.1.

Comment 34 Dawid Zamirski 2010-01-27 15:00:43 UTC
Hi Michael,

It's been a while :-) I have just installed the 2.2 version including the ffaudio plugin and my MPC files play fine now. I think this bug can be closed :-)

Thanks for your help!

Comment 35 Fedora Update System 2010-02-01 01:23:49 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-10.fc12.pl14, audacious-2.2-10.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update audacious-plugin-fc audacious-plugins audacious'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0028

Comment 36 Fedora Update System 2010-02-02 01:09:10 UTC
audacious-plugin-fc-0.4-1.fc12.2, audacious-plugins-2.2-10.fc12.pl14, audacious-2.2-10.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.