Bug 537303 - Summary: nokogiri emits warning re LibXML version 2.7.3
Summary: Summary: nokogiri emits warning re LibXML version 2.7.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-nokogiri
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-13 04:46 UTC by Bruce Jerrick
Modified: 2009-12-03 05:12 UTC (History)
2 users (show)

Fixed In Version: 1.3.3-3.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-03 05:03:10 UTC


Attachments (Terms of Use)

Description Bruce Jerrick 2009-11-13 04:46:37 UTC
Description of problem:
When /usr/bin/nokogiri is run (either directly or via a ruby-mechanize
script), it emits a warning re LibXML version 2.7.3 (current version of
that is 2.7.6).

Version-Release number of selected component (if applicable):
ruby-nokogiri-1.3.3-2.fc12
ruby-nokogiri-1.3.3-1.fc11
(source is rubygem-nokogiri)

How reproducible:
100%

Steps to Reproduce:
1. /usr/bin/nokogiri -v
or:
1. echo "require 'mechanize'" | ruby
  
Actual results:
WARNING: Nokogiri was built against LibXML version 2.7.3, but has dynamically loaded 2.7.6

Expected results:
No warning.

Additional info:
Neither package has been rebuilt since Aug 21 2009.

Comment 1 Mamoru TASAKA 2009-11-13 11:31:16 UTC
I don't think this warning should be fixed.

Comment 2 Bug Zapper 2009-11-16 15:30:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Fedora Update System 2009-12-01 18:08:40 UTC
rubygem-nokogiri-1.3.3-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rubygem-nokogiri-1.3.3-3.fc12

Comment 4 Fedora Update System 2009-12-01 18:09:22 UTC
rubygem-nokogiri-1.3.3-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rubygem-nokogiri-1.3.3-3.fc11

Comment 5 Fedora Update System 2009-12-03 05:03:06 UTC
rubygem-nokogiri-1.3.3-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2009-12-03 05:12:56 UTC
rubygem-nokogiri-1.3.3-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.