Bug 53743 - groff is hardwired to US Letter paper format, not A4
Summary: groff is hardwired to US Letter paper format, not A4
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: groff   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-17 17:28 UTC by Markus Kuhn
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-11 09:49:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Markus Kuhn 2001-09-17 17:28:41 UTC
Description of Problem:

Formatting a man page with "groff -man somemanpage.1" leads to a postscript
file that is formatted for usletter paper, even when the system was
installed outside the United States or Canada (e.g., in the UK), where this
paper format is unknown and everyone uses the international standard format
(ISO A4, see http://www.cl.cam.ac.uk/~mgk25/iso-paper.html).

Version-Release number of selected component (if applicable):

groff-1.16.1-7

Suggested fix:
	
In the file /usr/share/groff/font/devps/DESC change the line

  paperlength 792000

to

  paperlength 841890

(paper hight measured in 72000th of an inch changes from 11 inch to 297 mm)
and in the file /usr/share/groff/tmac/man.local add the line

  .mso tmac.a4

unless the installation script knows that the system is configured for
North America only, for example because the file /etc/sysconfig/i18n
contains a line matching 'LANG="*_US"' or 'LANG="*_CA"'.

Markus Kuhn, University of Cambridge

Comment 1 Florian La Roche 2003-01-11 09:49:04 UTC
I leave this for upstream groff sources to implement the
right strategies and they seem to keep to "legal" no matter
what language code is setup.

greetings,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.