Bug 53749 - xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/Type1 (unreadable)
xfs: ignoring font path element /usr/X11R6/lib/X11/fonts/Type1 (unreadable)
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-17 15:12 EDT by Andrew Meredith
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 15:16:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch that got scrunched by the text entry screen (653 bytes, patch)
2001-09-17 15:16 EDT, Andrew Meredith
no flags Details | Diff

  None (edit)
Description Andrew Meredith 2001-09-17 15:12:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.4-laptop i686)

Description of problem:
xfs refuses to add fonts from the /usr/X11R6/lib/X11/fonts/Type1 font
directory. This causes major problems. The X server refuses to start and
even if you get to fire up, the majority of programs die young.

The problem seems to be:

# diff -c /usr/X11R6/lib/X11/fonts/Type1/fonts.scale.orig
/usr/X11R6/lib/X11/fonts/Type1/fonts.scale
*** /usr/X11R6/lib/X11/fonts/Type1/fonts.scale.orig	Mon Sep 17 20:07:18
2001
--- /usr/X11R6/lib/X11/fonts/Type1/fonts.scale	Mon Sep 17 20:07:24 2001
***************
*** 64,70 ****
  lcdxmo.pfa -b&h-lucidux mono-medium-o-normal--0-0-0-0-m-0-iso8859-4
  lcdxmo.pfa -b&h-lucidux mono-medium-o-normal--0-0-0-0-m-0-iso8859-9
  lcdxmo.pfa -b&h-lucidux mono-medium-o-normal--0-0-0-0-m-0-iso8859-15
- 40
  alexb___.pfb
-ulT1mo-Alexandria-bold-r-normal--0-0-0-0-p-0-adobe-fontspecific
  alexbi__.pfb
-ulT1mo-Alexandria-bold-i-normal--0-0-0-0-p-0-adobe-fontspecific
  alexi___.pfb
-ulT1mo-Alexandria-medium-i-normal--0-0-0-0-p-0-adobe-fontspecific
--- 64,69 ----

With this line removed, mkfontdir creates a decent fonts.dir file, xfs
accepts the fonts.dir file and processes the directory. The fonts from that
directory get added to the system and the stuff that barfed doen't barf.

What I don't know is if the presence of a number alone on a line in a
fonts.scale file is actually valid. None of the other fonts.scale files on
my system has this format though and I have installed all the font packages
I could lay my grubby hands on.

My guess ... dump the 40 :)

Hope this helps

Andy Meredith

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install the whole of the current rawhide series
2.try and get X to work
	

Additional info:
Comment 1 Andrew Meredith 2001-09-17 15:16:54 EDT
Created attachment 31918 [details]
The patch that got scrunched by the text entry screen
Comment 2 Mike A. Harris 2001-09-22 05:11:57 EDT
This is an ancient bug that was fixed ages ago.  Your XFree86 needs
updating.
Comment 3 Andrew Meredith 2001-09-22 08:33:47 EDT
Unfortunately it seemed to take a long time for thrawhide version of XFree86 to
catch up with the fix. The current version now has this fix and all is well.

Note You need to log in before you can comment on or make changes to this bug.