Bug 537499 - GLib:ERROR:grel.c:303:g_relation_select_tuple: assertion failed: (tuple_key == tuple_value) Aborted (core dumped)
Summary: GLib:ERROR:grel.c:303:g_relation_select_tuple: assertion failed: (tuple_key =...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:90621f08661fd39c7d2d63b38d5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-13 21:27 UTC by Michael Schwendt
Modified: 2009-12-22 04:55 UTC (History)
2 users (show)

Fixed In Version: 3.7.3-2.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-22 04:42:09 UTC


Attachments (Terms of Use)
backtrace created by abrt (13.26 KB, text/plain)
2009-11-13 21:35 UTC, Michael Schwendt
no flags Details

Description Michael Schwendt 2009-11-13 21:27:10 UTC
abrt detected a crash.

How to reproduce
-----
1. Configure to use Google Mail via IMAP.
2. Open folder with > 100 messages, Select All, Delete.
3. Segfault (reproducible), also with Fedora 11.

cmdline: claws-mail
component: claws-mail
executable: /usr/bin/claws-mail
kernel: 2.6.31.5-127.fc12.i686.PAE
package: claws-mail-3.7.3-1.fc12
rating: 4
reason: Process was terminated by signal 6

Comment 1 Michael Schwendt 2009-11-13 21:35:23 UTC
Created attachment 369491 [details]
backtrace created by abrt

Comment 2 Michael Schwendt 2009-11-19 19:14:03 UTC
The related console output is this:

$ claws-mail 
**
GLib:ERROR:grel.c:303:g_relation_select_tuple: assertion failed: (tuple_key == tuple_value)
Aborted (core dumped)

So far it is specific to Google Mail.

Comment 3 Colin Leroy 2009-11-25 08:57:55 UTC
This is filed upstream as http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2063

Comment 4 Andreas Bierfert 2009-11-25 18:42:12 UTC
Here is a f12 scratch build containing the patch:
https://koji.fedoraproject.org/koji/taskinfo?taskID=1830875

Comment 5 Michael Schwendt 2009-11-25 19:07:26 UTC
Works for me. [I've sucessfully emptied two test-case folders, one with 139 messages, another with ~1200.]

Comment 6 Fedora Update System 2009-11-25 20:19:48 UTC
claws-mail-3.7.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/claws-mail-3.7.3-2.fc11

Comment 7 Fedora Update System 2009-11-25 20:20:19 UTC
claws-mail-3.7.3-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/claws-mail-3.7.3-2.fc12

Comment 8 Fedora Update System 2009-11-27 21:43:26 UTC
claws-mail-3.7.3-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update claws-mail'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12232

Comment 9 Fedora Update System 2009-12-22 04:42:05 UTC
claws-mail-3.7.3-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2009-12-22 04:55:34 UTC
claws-mail-3.7.3-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.