Bug 537536 - eclipse-swt has broken symlink
eclipse-swt has broken symlink
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
ppc64 Linux
low Severity urgent
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 540179
  Show dependency treegraph
 
Reported: 2009-11-14 02:34 EST by Orcan Ogetbil
Modified: 2009-12-08 02:44 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.5.1-20.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-08 02:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orcan Ogetbil 2009-11-14 02:34:31 EST
Bad news.

eclipse-swt-3.5.1-4.fc12.ppc64 has a broken symlink in /usr/lib64/eclipse
In particular,
swt-gtk-3.5.1.jar -> plugins/org.eclipse.swt.gtk.linux.ppc64_.jar
This has to be
swt-gtk-3.5.1.jar -> plugins/org.eclipse.swt.gtk.linux.ppc64_3.5.1.v3550b.jar

Because of this, 
- ALL PACKAGES that depend on eclipse-swt will FAIL TO BUILD in all archs because koji stops when one arch fails!
- Those that were built before the eclipse update will FAIL TO RUN on ppc64!

This needs to be fixed immediately!

As an example, the same package (tuxguitar) with the same SRPM built on F-10, F-11, F-13 but it failed on F-12:
   http://koji.fedoraproject.org/koji/taskinfo?taskID=1805940
Comment 1 Fedora Update System 2009-11-17 17:43:09 EST
eclipse-3.5.1-20.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/eclipse-3.5.1-20.fc12
Comment 2 Fedora Update System 2009-11-20 00:36:58 EST
eclipse-3.5.1-20.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11860
Comment 3 Fedora Update System 2009-12-08 02:44:51 EST
eclipse-3.5.1-20.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.