Bug 53757 - tar utility changes in 7.1 incompatible with other UNIX platforms
tar utility changes in 7.1 incompatible with other UNIX platforms
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-17 16:32 EDT by Jim Lord
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 09:30:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tar file that reproduces the problem. (568.64 KB, patch)
2001-09-18 09:30 EDT, Jim Lord
no flags Details | Diff

  None (edit)
Description Jim Lord 2001-09-17 16:32:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (WinNT; U)

Description of problem:
The GNU tar that ships with 7.1 is giving me an error when untarring kits that untar'ed on previous versions of the Linux OS.

when I execute the command:    tar xfv vload01.00-p004.t, I see the error:
tar:  ## garbage bytes ignored at end of archive
tar:  Error exit delayed from previous errors

The error status kills the execution of our installation tool.

We have tarkits known as "independent" kits because the contents are the same for ALL UNIX platforms.  It was bad enough that I had to 
work around the Linux tar's  "EOF error"  by creating a wrapper script around tar that used the blocking factor of 1, but now this new error 
has stopped us from being able to qualify 7.1 as a usuable Linux O/S for our software.

Is there a known workaround that will allow us to untar this tarfiles without the "garbage" error?



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Create a tarkit on Solaris, HPPA, or AIX
2.untar it on Linux
3.
	

Additional info:
Comment 1 Bernhard Rosenkraenzer 2001-09-18 04:57:55 EDT
Please attach a sample tar file showing this problem.
Comment 2 Jim Lord 2001-09-18 09:30:42 EDT
Created attachment 32018 [details]
Tar file that reproduces the problem.
Comment 3 Bernhard Rosenkraenzer 2001-09-27 12:42:21 EDT
Fixed in tar-1.13.25-1.

Note You need to log in before you can comment on or make changes to this bug.