Bug 53759 - kickstart: partition --ondisk fails without --size
kickstart: partition --ondisk fails without --size
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-17 17:18 EDT by Mike McLean
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 12:09:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael A. McLean 2001-09-17 17:18:11 EDT
* re0917.1-ia64
* ia64 / any / any / minimal / Kickstart Install

Description of Problem:

Doing a kickstart install, the partition line for /boot/efi, which should
select an existing partition, gives a traceback complaining that the size
must be specified.  For an existing partition, this should not be
necessary.  Note, that these lines come directly from the anaconda-ks.cfg
file of a previous install.

e.g. something like
part /boot/efi --fstype vfat --onpart /dev/hda1
Comment 1 Josep Guallar-Esteve 2001-09-17 17:33:18 EDT
* test tree re0917.1 IA64

Installed a system with Kickstart. The ks.cfg file had this partitions section:

(...)
clearpart --linux --drives=sda
part /boot/efi --fstype vfat --size=100 --ondisk=sda
part swap --size=1000 --grow --maxsize=2000 --ondisk=sda
part / --fstype ext3 --size=700 --grow --ondisk=sda
(...)

I think that it did not format the /boot/efi partition: The 
/tmp/install.log said that kernel....rpm package was not installed because it 
already was there!

After finishing install, at /root/anacondaks.cfg, I found this partition 
section:

(...)
#clearpart --linux
#part /boot/efi --fstype vfat --noformat --onpart sda1
#part swap --size=1000 --grow --maxsize=2000 --ondisk=sda
#part / --fstype ext3 --size=700 --grow --ondisk=sda
(...)

Note the part on /boot/efi and how it is different of the ks.cfg part, 
specially the "--noformat" part.
Comment 2 Jeremy Katz 2001-09-18 12:09:22 EDT
First one fixed on the anaconda-7-2-branch... still looking at the second one
(which is something completely different)
Comment 3 Jeremy Katz 2001-09-18 15:49:04 EDT
Patch for the second bits being floated past anaconda-list first to avoid silly
problems; should be in CVS later today though.

Note You need to log in before you can comment on or make changes to this bug.