Bug 537650 - wpa via NM keeps connecting and disconnecting
wpa via NM keeps connecting and disconnecting
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-15 08:30 EST by Radek Vokal
Modified: 2010-12-03 22:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 22:18:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (12.47 KB, text/plain)
2009-11-15 08:30 EST, Radek Vokal
no flags Details
dmesg | grep wlan 0 (2.19 KB, text/plain)
2009-11-16 02:52 EST, Radek Vokal
no flags Details

  None (edit)
Description Radek Vokal 2009-11-15 08:30:49 EST
Created attachment 369586 [details]
/var/log/messages

Description of problem:
NM keeps connecting and disconnecting to wifi network using WPA. The password is correctly set, NM connects to wireless network, the connection is established, ping works. After few seconds the it disconnects and asks again for wpa password, connects again and again disconnects. 

Version-Release number of selected component (if applicable):
NetworkManager-0.7.996-6.git20091021.fc12.i686
wpa_supplicant-0.6.8-6.fc12.i686


How reproducible:
Always

Steps to Reproduce:
1. Connect to wiki network using WPA
2. Observe connection being established
3. Observe connection being disconnected
  
Actual results:
No wifi

Expected results:
Stable connection

Additional info:
Attached is log with one connect/disconnect round
Comment 1 Dan Williams 2009-11-16 01:59:49 EST
Can you grab 'dmesg' output too so we can see what the kernel driver is saying?  Should be a lot of stuff like:

wlan0: authenticate with AP 00:12:17:ca:d9:28
wlan0: authenticated
wlan0: associate with AP 00:12:17:ca:d9:28
wlan0: RX AssocResp from 00:12:17:ca:d9:28 (capab=0x411 status=0 aid=7)
wlan0: associated

etc, though yours will likely say more about why the card is dropping the connection.
Comment 2 Radek Vokal 2009-11-16 02:52:28 EST
Created attachment 369654 [details]
dmesg | grep wlan 0

You're right, there's some mess with my AP.

BTW it worked perfectly with F-11, the box is updated to F-12.
Comment 3 Dan Williams 2009-11-17 03:44:06 EST
Yeah, you AP seems screwed now.

12 = "Association denied due to reason outside the scope of this standard"

(where "this standard" == 802.11)

does rebooting the AP help?  Sometimes they need that.
Comment 4 Radek Vokal 2009-11-17 05:25:54 EST
Hmm, so rebooting the AP doesn't help. Right now I have two laptops with same behaviour. On both, Fedora 11 works fine, one is updated to F12 (Lenovo R60) and I've tried F12 Live on Dell D620 where the result is pretty much the same thing. It's really weird that this works with F11 and the Dell laptop keeps connection forever ..
Comment 5 Dan Williams 2009-11-17 14:55:35 EST
Ok, so if F11 consistently works but F12 does not, that points to a kernel driver/stack problem I think.  Are you familiar with wpa_supplicant's config file and would you be willing to try a manual supplicant connection to isolate the issue?
Comment 6 Bug Zapper 2010-11-04 02:23:54 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2010-12-03 22:18:53 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.