Bug 53767 - Need to be able to undo prelink
Need to be able to undo prelink
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: prelink (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-17 21:26 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version: 0.2.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-06 03:29:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-17 21:26:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
With roswell installed and prelinking enabled, the loki_patch utility from
loki software will not run (with an error from ld.so).
I cannot disable prelinking to test whether that is the cause of the
problem. If prelinking can cause problems with executing programs it must
be undoable for the release.
BTW: Is there a manual way to undo prelinking?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. prelink --all
2. prelink --undo --all
	

Actual Results:  watch as undo appears to prelink again!


Expected Results:  # prelink --undo --all
prelink: Undone!

Additional info:
Comment 1 Jakub Jelinek 2001-09-18 03:32:11 EDT
--undo is not finished yet, it is a planned feature (together with even
harder to do --verify). It won't be able to restore identical binaries/libraries
unless the binaries/libraries have been linked with recent linker (ie.
-z combreloc), because relocs are ordered randomly.
But my current TODO list first includes more section moving magic for binaries
(so that even programs like kmail requiring lots of conflicts will work),
then test/possibly fix alpha/sparc ports, write ppc and ia64 port and then
get to undo/verify.
Note that prelink will be only in preview for the upcoming distribution.
But of course if you manage to prove it is prelink which breaks things
I'm interested in testcases (the safest undo way is ATM
prelink -avmn first, sed the output into list of files which need to be saved
and hardlink list (ln -f x y style shell script) and move the files which need
to be saved somewhere.
Also look at latest prelink, there are several bugfixes:
ftp://people.redhat.com/jakub/prelink/
Comment 2 Jakub Jelinek 2003-10-06 03:29:32 EDT
--undo is supported since 0.2.0-1.

Note You need to log in before you can comment on or make changes to this bug.