Bug 537677 - [abrt] crash detected in scribus-1.3.5.1-4.fc12
Summary: [abrt] crash detected in scribus-1.3.5.1-4.fc12
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: scribus
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL: http://bugs.scribus.net/view.php?id=8595
Whiteboard: abrt_hash:d246eeca5404f7094b6d293497f...
: 540278 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-15 17:38 UTC by Mihai Harpau
Modified: 2009-12-08 07:45 UTC (History)
2 users (show)

Fixed In Version: 1.3.5.1-5.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-08 07:43:23 UTC


Attachments (Terms of Use)
File: backtrace (45.73 KB, text/plain)
2009-11-15 17:39 UTC, Mihai Harpau
no flags Details

Description Mihai Harpau 2009-11-15 17:38:57 UTC
abrt detected a crash.

Comment: I preview the Color Management preferences and push Defaults button
Attached file: backtrace
cmdline: scribus
component: scribus
executable: /usr/bin/scribus
kernel: 2.6.31.5-127.fc12.x86_64
package: scribus-1.3.5.1-4.fc12
rating: 3
reason: Process was terminated by signal 11

Comment 1 Mihai Harpau 2009-11-15 17:39:02 UTC
Created attachment 369611 [details]
File: backtrace

Comment 2 Dan Horák 2009-11-21 09:15:47 UTC
Mihai, are you able to reproduce the crash?

Comment 3 Mihai Harpau 2009-11-22 23:32:57 UTC
Well, I tried again on another system and I could not reproduce the crash but second system was an F12 clean install and first one was an upgrade F11 -> F12 if that does matter.

Comment 4 Dan Horák 2009-11-23 07:55:32 UTC
*** Bug 540278 has been marked as a duplicate of this bug. ***

Comment 5 Dan Horák 2009-11-23 09:46:34 UTC
I have prepared an updated package that should fix this bug, please grab the package from http://koji.fedoraproject.org/koji/taskinfo?taskID=1824335 (after the task finishes)

Also from my reading of the scribus code it looks to me that the primary cause for the crashes could be a broken file with the hyphenation rules. Does the hyphenator works for you?

Comment 6 Mihai Harpau 2009-11-24 18:39:04 UTC
Seems to me that the updated package of scribus does run without any problem. Until now I don't tried any hyphenation rule (I am a very beginner in scribus).

Comment 7 Dan Horák 2009-11-25 10:16:21 UTC
Mihai, thanks for the test, the fix was accepted by Scribus upstream into all releases. I will prepare an official update soon.

Comment 8 Fedora Update System 2009-11-26 11:17:26 UTC
scribus-1.3.5.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/scribus-1.3.5.1-2.fc10

Comment 9 Fedora Update System 2009-11-26 11:17:31 UTC
scribus-1.3.5.1-5.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/scribus-1.3.5.1-5.fc12

Comment 10 Fedora Update System 2009-11-26 11:17:35 UTC
scribus-1.3.5.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/scribus-1.3.5.1-2.fc11

Comment 11 Fedora Update System 2009-11-27 21:52:45 UTC
scribus-1.3.5.1-5.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scribus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12265

Comment 12 Fedora Update System 2009-11-27 21:59:31 UTC
scribus-1.3.5.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scribus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-12290

Comment 13 Fedora Update System 2009-11-27 22:08:36 UTC
scribus-1.3.5.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update scribus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-12325

Comment 14 Fedora Update System 2009-12-08 07:43:18 UTC
scribus-1.3.5.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2009-12-08 07:44:01 UTC
scribus-1.3.5.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2009-12-08 07:45:26 UTC
scribus-1.3.5.1-5.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.