Bug 537682 - "service" ignores LANG or LC_ALL or so
Summary: "service" ignores LANG or LC_ALL or so
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 12
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-15 18:21 UTC by Mamoru TASAKA
Modified: 2014-03-17 03:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-16 18:42:45 UTC
Type: ---


Attachments (Terms of Use)

Description Mamoru TASAKA 2009-11-15 18:21:29 UTC
Description of problem:
For example with
initscripts-9.02-1.i686
hal-0.5.13-9.fc12.i686

[root@localhost ~]# locale
LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=C
[root@localhost ~]# service haldaemon status
hald (pid 1385) を実行中...

i.e. anyway "service" command shows Japanese messages.

Version-Release number of selected component (if applicable):
initscripts-9.02-1.i686
and others

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:
See above

Expected results:
[root@localhost ~]# service haldaemon status
hald (pid 1385) is running...

Additional info:
[root@localhost ~]# cat /etc/sysconfig/i18n 
LANG="ja_JP.UTF-8"
SUPPORTED="ja_JP.UTF-8:ja_JP:ja"
SYSFONT="latarcyrheb-sun16"

Comment 1 Bug Zapper 2009-11-16 15:33:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Bill Nottingham 2009-11-16 18:42:45 UTC
service explicitly ignores the passed environment, by design.


Note You need to log in before you can comment on or make changes to this bug.