Bug 53777 - fftw pr dfftw? rfftw or drfftw?
fftw pr dfftw? rfftw or drfftw?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Powertools
Classification: Retired
Component: fftw (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-18 09:32 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 10:44:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-18 09:32:03 EDT
Hi!

I am trying to compile a program called Grass5 on my RedHat 7.1 box (Intel)
This program uses the fftw library and uses a file called fftw.h

I have installed the Powertools FFTW packages and I discovered that there
is no fftw.h file in it.
I went to the www.fftw.org webserver and I downloaded and rebuilt the
RedHat package provided there. This package contains the fftw.h file

Curious, I compared the fftw.org and the redhat packages to discover that
in the redhat packages fftw has been renamed dfftw (headers and libraries)
and rfftw had been renamed drfftw (headers and libraries).

Now my questions:
Why is it so?
Wouldn't it be possible to create links from dfftw to fftw and from drfftw
to rfftw?


Thanks in advance for any answer


Daniel Tourde
Comment 1 Bernhard Rosenkraenzer 2002-01-18 11:59:28 EST
Since Powertools was discontinued and this is not bad enough to warrant an
errata release, there is nothing I can do about it, unfortunately (so the
official fix is the removal of the package from current products).

To your question: Red Hat did not rename fftw to dfftw. If fftw is built both in
single-precision and double-precision mode, the fftw build process automatically
names the binaries sfftw (s.p.) and dfftw (d.p.). The fftw.org RPM probably
supports only one of them.

Note You need to log in before you can comment on or make changes to this bug.