Bug 537866 - [abrt] crash detected in java-1.6.0-openjdk-1:1.6.0.0-33.b16.fc12
[abrt] crash detected in java-1.6.0-openjdk-1:1.6.0.0-33.b16.fc12
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eclipse-subclipse (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Robert Marcano
Fedora Extras Quality Assurance
abrt_hash:ad9e8ea18662650d40b0d673830...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 10:51 EST by Morten Slott Hansen
Modified: 2010-11-10 02:03 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 02:03:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (38.27 KB, text/plain)
2009-11-16 10:51 EST, Morten Slott Hansen
no flags Details
File: cmdline (785 bytes, text/plain)
2009-11-16 10:51 EST, Morten Slott Hansen
no flags Details

  None (edit)
Description Morten Slott Hansen 2009-11-16 10:51:17 EST
abrt detected a crash.

Attached file: backtrace
Attached file: cmdline
component: java-1.6.0-openjdk
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
kernel: 2.6.31.1-56.fc12.x86_64
package: java-1.6.0-openjdk-1:1.6.0.0-33.b16.fc12
rating: 1
reason: Process was terminated by signal 6
Comment 1 Morten Slott Hansen 2009-11-16 10:51:21 EST
Created attachment 369724 [details]
File: backtrace
Comment 2 Morten Slott Hansen 2009-11-16 10:51:23 EST
Created attachment 369725 [details]
File: cmdline
Comment 3 Mark Wielaard 2009-11-17 06:24:12 EST
The problematic stack seems to be the following where for getting the svn credentials KWallet is used, which triggers some assertion check abort when it calls into gtk/X again:

Thread 1 (Thread 2294):
#0  0x00007f5681486605 in raise () from /lib64/libc.so.6
No symbol table info available.
#1  0x00007f5681487de5 in abort () from /lib64/libc.so.6
No symbol table info available.
#2  0x00007f568147f6f5 in __assert_fail () from /lib64/libc.so.6
No symbol table info available.
#3  0x00007f5649acc03d in ?? () from /usr/lib64/libX11.so.6
No symbol table info available.
#4  0x00007f5649acc877 in _XEventsQueued () from /usr/lib64/libX11.so.6
No symbol table info available.
#5  0x00007f5649ab512d in XPending () from /usr/lib64/libX11.so.6
No symbol table info available.
#6  0x00007f564b0628f9 in ?? () from /usr/lib64/libgdk-x11-2.0.so.0
No symbol table info available.
#7  0x00007f564b2fc12a in g_main_context_check () from /lib64/libglib-2.0.so.0
No symbol table info available.
#8  0x00007f564b2fc90d in ?? () from /lib64/libglib-2.0.so.0
No symbol table info available.
#9  0x00007f564b2fcd3a in g_main_context_iteration ()
   from /lib64/libglib-2.0.so.0
No symbol table info available.
#10 0x00007f55f98a0ac6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
No symbol table info available.
#11 0x00007f55f9876212 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
No symbol table info available.
#12 0x00007f55f98765ec in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
No symbol table info available.
#13 0x00007f55f801834e in KWallet::Wallet::openWallet(QString const&, unsigned long, KWallet::Wallet::OpenType) () from /usr/lib64/libkdeui.so.5
No symbol table info available.
#14 0x00007f55f9b978c1 in svn_auth__ssl_client_cert_pw_file_first_creds_helper
    () from /usr/lib64/libsvn_auth_kwallet-1.so.0
No symbol table info available.
#15 0x00007f55f9b97cc5 in ?? () from /usr/lib64/libsvn_auth_kwallet-1.so.0
No symbol table info available.
#16 0x00007f55fb1a81ae in svn_auth__simple_save_creds_helper ()
   from /usr/lib64/libsvn_subr-1.so.0
No symbol table info available.
#17 0x00007f55f9b97980 in ?? () from /usr/lib64/libsvn_auth_kwallet-1.so.0
No symbol table info available.
#18 0x00007f55fb18c8e8 in svn_auth_save_credentials ()
   from /usr/lib64/libsvn_subr-1.so.0
No symbol table info available.
#19 0x00007f55fcf57252 in svn_client__get_revision_number ()
   from /usr/lib64/libsvn_client-1.so.0
No symbol table info available.
#20 0x00007f55fcf53f91 in svn_client__repos_locations ()
   from /usr/lib64/libsvn_client-1.so.0
No symbol table info available.
#21 0x00007f55fcf54469 in svn_client__ra_session_from_path ()
   from /usr/lib64/libsvn_client-1.so.0
No symbol table info available.
#22 0x00007f55fcf3f654 in svn_client_info2 ()
   from /usr/lib64/libsvn_client-1.so.0
No symbol table info available.
#23 0x00007f5608a457e5 in SVNClient::info2(char const*, Revision&, Revision&, svn_depth_t, StringArray&, InfoCallback*) ()
   from /usr/lib64/libsvnjavahl-1.so.0.0.0
No symbol table info available.
#24 0x00007f5608a4e622 in Java_org_tigris_subversion_javahl_SVNClient_info2 ()
   from /usr/lib64/libsvnjavahl-1.so.0.0.0
No symbol table info available.
#25 0x00007f56787d9f50 in ?? ()
No symbol table info available.
#26 0x0000000000000000 in ?? ()
No symbol table info available.


I think this is an issue with gtk+/qt interaction. Reassigning to eclipse to figure out why/how this mismatch is happening.
Comment 4 Andrew Overholt 2009-11-17 08:48:01 EST
This looks like a crash somewhere between Subclipse and svn-javahl.
Comment 5 Bug Zapper 2010-03-15 09:02:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Alexander Kurtakov 2010-11-09 10:57:35 EST
Is this bug still reproducible?
Comment 7 Morten Slott Hansen 2010-11-10 02:03:48 EST
I have not seen it crash since - so I recon all is good :)

Note You need to log in before you can comment on or make changes to this bug.