Bug 537887 - patch - honor --noipv6 within modprobe.conf
patch - honor --noipv6 within modprobe.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.5
All Linux
high Severity medium
: rc
: ---
Assigned To: David Cantrell
Release Test Team
:
: 649019 (view as bug list)
Depends On:
Blocks: 600484
  Show dependency treegraph
 
Reported: 2009-11-16 12:14 EST by Adam Stokes
Modified: 2013-07-11 20:02 EDT (History)
10 users (show)

See Also:
Fixed In Version: anaconda-11.1.2.218-1
Doc Type: Bug Fix
Doc Text:
Previously, the network --noipv6 kickstart command configured /etc/sysconfig/network but did not alter modprobe.conf. Therefore, even when --noipv6 was specified, modprobe would still load the kernel IPv6 modules. The --noipv6 option now disables IPv6 in modprobe.conf too, so the IPv6 kernel modules do not load. (#537887)
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 16:53:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to alter modprobe.conf (1.00 KB, patch)
2009-11-16 12:14 EST, Adam Stokes
no flags Details | Diff
anaconda.syslog (15.05 KB, text/plain)
2010-10-05 12:21 EDT, Alexander Todorov
no flags Details
anaconda.log (280.09 KB, text/plain)
2010-10-05 12:22 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Adam Stokes 2009-11-16 12:14:08 EST
Created attachment 369749 [details]
patch to alter modprobe.conf

Description of problem:
When using noipv6 it only places a configuration option in /etc/sysconfig/network but modprobe.conf also needs to be altered as well.

Version-Release number of selected component (if applicable):
anaconda-11.x

How reproducible:
100%

Steps to Reproduce:
1. run with --noipv6
2.
3.
  
Actual results:
modprobe.conf still enables ipv6 modules

Expected results:
system should not load ipv6 

Additional info:
Comment 1 Adam Stokes 2009-11-16 13:50:28 EST
Also I have a question as to if we want to disable ip6tables through the same route rather than accessing it through ksdata.services?

Thanks,
Adam
Comment 2 joshua 2009-11-18 13:58:54 EST
I'm not sure this is the right approach.  If kickstart or anything else makes /etc/sysconfig/network contain NETWORKING_IPV6=no, it should be considered finished.

Shouldn't the ip6tables and network script then behave appropriately?

Seems like once that is in /etc/sysconfig/network, the network script shouldn't load or activate ipv6 functionality.  The bug to my mind at least isn't that kickstart didn't add a bunch of lines to modprobe.conf
Comment 10 Alexander Todorov 2010-10-05 12:20:34 EDT
Installed with network --device eth0 --bootproto dhcp --noipv6
and the resulting modprobe.conf was:

alias scsi_hostadapter ata_piix
alias eth0 virtio_net
alias scsi_hostadapter1 virtio_blk
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
options snd-intel8x0 index=0
remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0


Not even near comment #7

/etc/sysconfig/network contains NETWORKING_IPV6=no


MOving back to ASSIGNED, will attach logs.
Comment 11 Alexander Todorov 2010-10-05 12:21:52 EDT
Created attachment 451719 [details]
anaconda.syslog
Comment 12 Alexander Todorov 2010-10-05 12:22:16 EDT
Created attachment 451720 [details]
anaconda.log
Comment 13 joshua 2010-10-05 13:45:35 EDT
It might make sense to make the network initialization scripts simply not activate IPV6 per an entry in the /etc/sysconfig/network file or something, instead of relying on anaconda to itself tweak files.
Comment 15 David Cantrell 2010-11-10 11:26:40 EST
*** Bug 649019 has been marked as a duplicate of this bug. ***
Comment 16 Alexander Todorov 2010-12-01 03:52:12 EST
Tested with snapshot #3 and
network --device eth0 --bootproto dhcp --noipv6

modprobe.conf now matches comment #7 and the patch from comment #0. Moving to VERIFIED.
Comment 17 Ruediger Landmann 2011-01-07 00:17:50 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the network --noipv6 boot option configured 
/etc/sysconfig/network but did not alter modprobe.conf. Therefore, even 
when --noipv6 was specified, modprobe would still load the kernel IPv6
modules. The --noipv6 option now disables IPv6 in modprobe.conf too, so
the IPv6 kernel modules do not load. (#537887)
Comment 18 Ruediger Landmann 2011-01-07 00:18:48 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
-Previously, the network --noipv6 boot option configured 
+Previously, the network --noipv6 kickstart command configured 
 /etc/sysconfig/network but did not alter modprobe.conf. Therefore, even 
 when --noipv6 was specified, modprobe would still load the kernel IPv6
 modules. The --noipv6 option now disables IPv6 in modprobe.conf too, so
Comment 20 errata-xmlrpc 2011-01-13 16:53:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0030.html

Note You need to log in before you can comment on or make changes to this bug.