Bug 537911 - openais init script cannot start service
Summary: openais init script cannot start service
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openais
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Steven Dake
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject
TreeView+ depends on / blocked
 
Reported: 2009-11-16 18:58 UTC by Nate Straz
Modified: 2016-04-26 18:14 UTC (History)
5 users (show)

Fixed In Version: openais-1.1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-22 05:52:40 UTC
Type: ---


Attachments (Terms of Use)
Patch to openais init script (455 bytes, patch)
2009-11-22 18:29 UTC, Tore Anderson
no flags Details | Diff

Description Nate Straz 2009-11-16 18:58:46 UTC
Description of problem:

When starting the openais service via the init script, it fails to start.
[root@morph-01 init.d]# service openais start
Starting OpenAIS (corosync): corosync [MAIN  ] Corosync Cluster Engine ('1.1.2'): started and ready to provide service.
corosync [MAIN  ] Corosync built-in features: nss rdma
corosync [MAIN  ] Corosync Executive couldn't open configuration component 'openaisserviceenable'
corosync [MAIN  ] Corosync Cluster Engine exiting with status -9 at main.c:900.
                                                           [FAILED]

It appears the export in the init script to set the config parser is incorrect.


Version-Release number of selected component (if applicable):
openais-1.1.0-1.fc12.i686

How reproducible:
Every time

Steps to Reproduce:
1. create /etc/corosync/openais.conf
2. service openais start
  
Actual results:


Expected results:


Additional info:

Comment 1 Steven Dake 2009-11-16 19:42:30 UTC
For individuals reading this bug, note the steps to reproduce are to have a proper /etc/corosync/corosync.conf.  /etc/corosync/openais.conf is not used.

The problem is that the export line in the init scripts should match that of /usr/sbin/aisexec.

Comment 2 Tore Anderson 2009-11-22 18:29:20 UTC
Created attachment 372942 [details]
Patch to openais init script

I spent quite a bit of time figuring out why on earth openais wouldn't start on my F12 test rig - having never played with it before it took a while before I finally figured it out.

I've attached a one-line patch that fixed it for me.

Tore

Comment 3 Steven Dake 2009-11-22 22:17:10 UTC
thanks merged upstream.  F12 updates are frozen at the moment but we will release an update as soon as the repos become unlocked.

regards
-steve

Comment 4 Fabio Massimo Di Nitto 2009-11-23 05:53:37 UTC
The repos for F12 are open (-updates). I can either fix this by pulling the single patch or wait for another upstream tarball release.

Steven, please let me know what you prefer and timeline for it. I am about to push an update for cluster very soon (aka one or max two days) and I can add openais to the pool.


Note You need to log in before you can comment on or make changes to this bug.