Bug 537959 - Cannot move panel between screens (dual head)
Summary: Cannot move panel between screens (dual head)
Keywords:
Status: CLOSED DUPLICATE of bug 494740
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 529398 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-11-16 22:54 UTC by David Le Sage
Modified: 2010-01-25 15:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-25 15:55:22 UTC
Type: ---


Attachments (Terms of Use)
Screenshot showing how panel defaults to the right-most display. (152.07 KB, image/png)
2009-11-16 23:05 UTC, David Le Sage
no flags Details

Description David Le Sage 2009-11-16 22:54:44 UTC
Description of problem:
In Fedora 11, the GNOME Panel would default to the left-most screen in a multi-screen configuration.  This probably made sense in terms of "Fitt's Law" in the sense that the GNOME Desktop Menus were then in the top left-hand corner of all displays.  


In Fedora 12, it seems that the GNOME Panel is now on the right-most screen.  There appears to be no way to configure it if the user prefers in on another screen.

Version-Release number of selected component (if applicable):
Fedora 12/GNOME 2.28.1

How reproducible:
Every time.

Steps to Reproduce:
1. Configure system with multiple monitors.
2. System->Preferences->Display Ensure the monitors are not "mirrored" (this is the new default, anyway.)
3. Note that there is no way to choose on which monitor the GNOME Panels are to be displayed.
  
Actual results:
No way to configure the panel on which the GNOME Panel is displayed.  As a result, it defaults to the right-most monitor which effectively puts it in the middle of the overall display if the two screens are regarded as one desktop.

Expected results:
GNOME Panel should default to the left-most display, as per Fedora 11 or there should be a way for the user to choose which display they are to appear upon, via the system-config-display tool.

Additional info:

Comment 1 David Le Sage 2009-11-16 23:05:55 UTC
Created attachment 369807 [details]
Screenshot showing how panel defaults to the right-most display.

Comment 2 Adam Jackson 2009-11-17 16:44:45 UTC
gnome-panel bug, not s-c-d bug.

Comment 3 Richard Schwarting 2009-11-18 23:36:08 UTC
I'll note that my dual-screen setup has GNOME Panel defaulting to the left screen.  

In this case, the left screen is my primary display (my laptops) and my right screen is the secondary display (a huge CRT).

If I swap the screens around logically in gnome display properties, the GNOME panel remains on my primary display, though the applications they hosted switch (so windows on the left screen which was my primary (laptop) screen are now on the left screen which is now my secondary (CRT) and vice versa).

So, your bug is actually a fix for an issue of mine: I want the GNOME Panel to stay on the Primary Display, which would be my laptop's, since my keyboard is attached to it.

Comment 4 David Le Sage 2009-11-18 23:53:45 UTC
Richard, You are correct in that the right-most display is my laptop, so the panel is indeed on my "primary" display.  


However, with Fedora 11, if the display was on the left-hand display (my auxiliary LCD) and I removed the laptop from its cradle, the panel was "smart enough" to move to the laptop display.  


My suggestion would be to make the panel configurable, so that one can decide for one's self which display it is to appear on.


Cheers,

David

Comment 5 David Le Sage 2009-11-19 23:01:57 UTC
Just a couple more thoughts on the logic of this, in response to Richard's comments above:


1. Richard indicates he wants the GNOME Panel to always reside on his primary display (the laptop.)  However, for many people, since the GNOME Panel is frequently accessed, it makes sense to have it on the larger, auxiliary LCD display.  (This depends on the individual's usage patterns.) 


2. Richard may find it convenient to have his laptop to the left of his auxiliary LCD display. However, if one has the mouse plugged into the laptop and one is also right handed, it means the mouse cord will be stretching around the person's keyboard and auxiliary display, meaning that potentially a lot of cable will be in the way of the user.


Therefore, as I assert above, enabling the person to configure on which display they want to the GNOME Panel to appear will probably the best option to fit the usability needs of all users.

Comment 6 Christopher Beland 2010-01-25 15:32:23 UTC
I also get my panel on the "primary" display with gnome-panel-2.28.0-16.fc12.i686, not leftmost or rightmost.  It would indeed be very nice to be able to move them between screens; I have no way to create one on my larger monitor unless I disable the smaller one.

Comment 7 Christopher Beland 2010-01-25 15:50:12 UTC
*** Bug 529398 has been marked as a duplicate of this bug. ***

Comment 8 Christopher Beland 2010-01-25 15:55:22 UTC
Bug 494740 notes that panels *can* be moved with Alt + drag, and I confirmed
that this works with gnome-panel-2.28.0-16.fc12.i686.

*** This bug has been marked as a duplicate of bug 494740 ***


Note You need to log in before you can comment on or make changes to this bug.