Bug 5380 - printtool fails to detect more than one printer port
Summary: printtool fails to detect more than one printer port
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printtool   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-26 20:34 UTC by tim
Modified: 2014-03-17 02:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-05 14:36:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tim 1999-09-26 20:34:35 UTC
Owing to the use of' elsif' in the auto-port-detection bit in printtool, only one port will ever be detected. The' elsif's need to change to' if's.

Comment 1 Bill Nottingham 1999-09-29 20:27:59 UTC
and actually, they should be cascaded, because with the
2.2 kernel, you'll never find a lp1 without an lp0...

Comment 2 Bill Nottingham 1999-10-05 14:36:59 UTC
Fixed in printtool-3.42-1, which will be in the next Raw Hide release.


Note You need to log in before you can comment on or make changes to this bug.