Bug 538028 - numpy doesn't support ARM architecture
numpy doesn't support ARM architecture
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
arm9 Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
EasyFix
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2009-11-17 05:40 EST by Jitesh Shah
Modified: 2009-11-17 14:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 10:57:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Add ARM support (3.57 KB, patch)
2009-11-17 05:40 EST, Jitesh Shah
no flags Details | Diff

  None (edit)
Description Jitesh Shah 2009-11-17 05:40:06 EST
Created attachment 369856 [details]
Add ARM support

Description of problem:
since numpy doesn't know about ARM, it cannot deduce its endianness. Thus, build fails.
Check out the build logs here
http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=19294

Version-Release number of selected component (if applicable):
any

Additional info:
Adding support for ARM should be fairly straightforward. Attaching a patch that adds the support. Find a successful build here:
http://arm.koji.fedoraproject.org/koji/buildinfo?buildID=21265
Comment 1 Jarod Wilson 2009-11-17 08:33:43 EST
Jitesh, the patch is much appreciated, and we can certainly take it into the build. If you haven't already, can you please submit this upstream to the rrdtool-developers mailing list?
Comment 2 Jon Ciesla 2009-11-17 08:51:29 EST
Jarod, was this comment on the wrong bug, perhaps?
Comment 3 Jarod Wilson 2009-11-17 09:05:26 EST
Hah! Wow. No, somehow, my brain translated numpy into rrdtool. So comment #1 holds, if you replace "rrdtool-developers mailing list" with "wherever the numpy devs prefer to accept patches". (I need more coffee...)
Comment 4 Jon Ciesla 2009-11-17 09:15:46 EST
I'm right there with you. :)  I'll start work on getting this into rawhide. . .
Comment 5 Jon Ciesla 2009-11-17 10:57:59 EST
Built.
Comment 6 Jitesh Shah 2009-11-17 14:44:35 EST
Jarod, okay I'll file the bug here : http://mail.scipy.org/mailman/listinfo/numpy-tickets. Although the last mail was in April 2009, which is not very heartening :-)

Also, I saw the koji build. It got built as "numpy-1.3.0-6.fc13.fa1". Guess I left an extra "fa1" in the Release. It should have been "numpy-1.3.0-7.fc13"
Comment 7 Jon Ciesla 2009-11-17 14:56:05 EST
The fa1 won't cause any problems.

Note You need to log in before you can comment on or make changes to this bug.